[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Error: ‘pdu’ has not been declared

From: Henning Bredenberg
Subject: [Discuss-gnuradio] Error: ‘pdu’ has not been declared
Date: Wed, 04 May 2016 10:26:06 +0200
User-agent: Horde Application Framework 5

Hi list,

I created an OOT module "work" and tried to copy the functions of blocks from the standard library with additional test-outputs for a better understanding. The block "pdu_to_tagged_stream" is copied in an own block called "tagged". Via following commands in the build direction I should be able to use this block in GRC.

cmake ../
sudo make install
sudo ldconfig

Following error occurs when i run make:

~/gnuradio/gr-work/build$ make
Scanning dependencies of target gnuradio-work
[  5%] Building CXX object lib/CMakeFiles/gnuradio-work.dir/tagged_impl.cc.o
In file included from /home/user1/gnuradio/gr-work/lib/tagged_impl.h:24:0,
                 from /home/user1/gnuradio/gr-work/lib/tagged_impl.cc:25:
/home/user1/gnuradio/gr-work/include/work/tagged.h:50:24: error: ‘pdu’ has not been declared static sptr make(pdu::vector_type type, const std::string& tsb_tag_key);

[...more errors including "‘pdu’ has not been declared"...]

make[2]: *** [lib/CMakeFiles/gnuradio-work.dir/tagged_impl.cc.o] Error 1
make[1]: *** [lib/CMakeFiles/gnuradio-work.dir/all] Error 2
make: *** [all] Error 2

I tried several things but since I'm not a skilled programmer I can't figure out what to change. Inserting "#include <gnuradio/blocks/pdu.h>" in the tagged.h file doesn't fix it. Anyone who can help me with this? If needed, i can add more information about the code.

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]