[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Build installation on Ubuntu

From: Mark Napier
Subject: Re: [Discuss-gnuradio] Build installation on Ubuntu
Date: Sun, 29 May 2016 20:12:59 -0400

So tried cleaning yet again, reinstalling recipes, and running init again.  This time it finished.  Everything is working out of a sandbox.

This is like macports: a monumental labor of love by many talented programmers.  I'm sure it will get more stable with time.

Would still very much like to know how to make the other commands in pybombs work:  the OOT modules and managing the ones already installed.


Mark Napier

On Sun, May 29, 2016 at 10:24 AM, Mark Napier <address@hidden> wrote:
Hello the camp,

I'm struggling with an installation on Ubuntu 16.04.  Note that apt-get does install a working GNUradio stack and UHD works with a USRP2.  However, my goal is to install a build environment.

For my 1st effort I used git to clone the uhd driver directory and was able to get a clean build from the source and the make test all worked correctly.  After make install uhd_usrp_probe finds the USRP2.  However, on connecting a GRC uhd source to waterfall sink the run fails.  The problem is that the UHD driver is newer than the apt-get installation of gnuradio so the two are incompatible.  Also, the gnuradio install doesn't seem to have the source for a build environment either.

So next effort is to try to use pybombs to install into a prefix directory.  Having all the source and being able to modify it and run in a local sandbox is exactly what I'm after.  Used apt-get to remove uhd and gnuradio.  But I'm finding pybombs difficult to use.

After a few emails from Martin at Ettus and a great deal of tinkering with permissions I can do the following:

$ pybombs recipes add gr-recipes git+https://github.com/gnuradio/gr-recipes.git
$ pybombs recipes add gr-etcetera git+https://github.com/gnuradio/gr-etcetera.git
$ pybombs prefix init  ~/gnuradio/src/prefix -R gnuradio-default

This will init my prefix directory and start the installation and compile of a sandbox.  However, it doesn't finish.  It get to bladeRF and aborts with "Unable to fetch recipe bladeRF".  Whats *much* more frustrating is that I can't get any other form of a pybombs command line to run and give me information about the prefix install.  I just get the "usage" statement.  And the init won't run after the first time, I get a:

PyBombs.prefix - ERROR - Ignoring. A prefix already exists in `/home/napierm/gnuradio/src/prefix'

So if I run:

rm -rf gnuradio/src/prefix/*
rm -rf gnuradio/src/prefix/.*

Then I can start over.  PyBOMBS is supposed to be able to show what is installed and manage/add modules.  Any ideas what to try next?

Thank you very much in advance,

Mark Napier

reply via email to

[Prev in Thread] Current Thread [Next in Thread]