[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] [PyBOMBS] Need your help!

From: Marcus Müller
Subject: Re: [Discuss-gnuradio] [PyBOMBS] Need your help!
Date: Mon, 30 May 2016 13:20:29 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.6.0

Hi Ravi,
The build fails due to the unmet dependency of Cheetah template engine. 
exactly that's why we depend on Python2 packages in python.lwr:
category: baseline
inherit: autoconf
  deb: python2.7 && python-dev
  rpm: python-devel >= 2.7
  cmd: python --version >= 2.7
  pacman: python2 >= 2.7
  port: python27 >= 2.7
  config_opt: --enable-shared

Notice the pacman line! So, if GNU Radio is currently building, you should have an install python2. If you don't, there's a bug in dependency checking.

I'd expect all our build scripts to explicitely specify that the python2 executable should be used. If you can give an actual bug report of where exactly building fails, this is probably something that's fixable.

Also, you said "need your help!", but then didn't ask a question or what exactly we should be helping you with :) So if I didn't hit the spot here, please explain what it is that you need help with.

Best regards,

On 30.05.2016 13:10, Ravi Sharan wrote:

Today, I have tried installing gnuradio on Antergos (Arch Linux based distro) using pybombs. Antergos ships Python3 as it's default python version and Cheetah seems to be incompatible with Python3. The build fails due to the unmet dependency of Cheetah template engine. 
The successful builds on Ubuntu 16.04 reported in this thread are because Ubuntu 16.04 claims to be shipping Python3.5.1 as it's default Python version, but it still has a good support for Python2.7.x. 

This issue of replacing Cheetah is slightly discussed at [1]. 


Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]