[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] problem with a fresh pybombs build

From: Nicholas McCarthy
Subject: Re: [Discuss-gnuradio] problem with a fresh pybombs build
Date: Thu, 13 Oct 2016 16:17:25 +0000

Hey Jason,

That's interesting... I was expecting it to prove your user saw a different version of setuptools than running sudo.  I think there's still evidence that may be the case, but I'm not sure.

I think your best bet for building gnuradio on your non-vanilla machine is to start from scratch assuming you do not have sudo privileges.

Assuming you have a reasonable python installed, you should be able to install pip using this.


Then pip install pybombs

Then use pybombs

However, if your ultimate goal is to work with your IT to get to the root of your bizzaro OS problems, then I would 
1. Do a pybombs install using your initial set of commands on a truly vanilla ubuntu (to prove that it works and to give your IT something to compare with the broken system).
2. Follow these same steps on your non-vanilla ubuntu to reproduce your error.
3. Dump the problem on your IT telling them to solve whatever permissions and system path problems they need to solve to make system 2 behave like system 1.

Nick M.

On Thu, Oct 13, 2016 at 11:24 AM Jason Matusiak <address@hidden> wrote:

Thank you for the info.  I've uninstalled pybombs everywhere, so I should be "clean" again.

I tried running your two easy_install commands and got an unexpected result:
address@hidden:~/Downloads$ easy_install --version
usage: easy_install [options] requirement_or_url ...
   or: easy_install --help

error: invalid command 'easy_install'
address@hidden:~/Downloads$ sudo easy_install --version
setuptools 28.3.0 from /usr/local/lib/python2.7/dist-packages (Python 2.7)

I sort of figured that the non-sudo version would give some sort of result based on your email.  Does this tell us something?



On 10/12/2016 02:58 PM, Nicholas McCarthy wrote:
So.... If I look at sys.path in python, I do see
(and I didn't do anything special to make this happen.)

Also, which pybombs points to

And my install location for pybombs is

From the standpoint of a fresh install (which you certainly no longer have), I think the problem comes in when you fail to have permissions on the pybombs bin... I suspect that's something to do with your weird sudo script and not pip or pybombs, but I'm not sure.  

If you could get back to the state you were in after your initial attempt to install, I'd like to know the value of your sys.path in python.  

Right now, you have a frankenbuild for pybombs thanks to running sudo with the --user flag... I would uninstall that, for sure and get to where you have no pybombs installed anywhere.

So... as for why you can't pip install pybombs (no sudo)... this has to be a setuptools thing. 

Maybe try
easy_install --version
sudo easy_install --version

to see if there's a difference.  Because your sudo is broken, you may have to do a lot of "sudo which blah" and "which blah" to find out what your problem is.

You can probably try an install without any sudo use by first sudo apt-get remove --purge pip and then downloading and using get-pip.py.  Then just pip install pybombs (no flags, no sudo, no nothing)... and try that one.

Nick M.

On Wed, Oct 12, 2016 at 1:13 PM Jason Matusiak <address@hidden> wrote:
Hi Nick!
I did.  When I run it I get:
Requirement already up-to-date: setuptools in /usr/local/lib/python2.7/dist-packages

I am not on a thin client, I am on a fresh load of 16.04 on an actual PC.  I do believe that sudo isn't actually sudo, but a script.  That said, I wasn't having sudo issues before I reloaded my machine (which was running 14.04).


On 10/12/2016 01:04 PM, Nicholas McCarthy wrote:
Jason, did you try 
pip install --upgrade setuptools

as a first step?  Are you running on a special setup such as a patchwork virtual machine being served to you on a thinclient with f**ed permissions?

Nick M.

On Wed, Oct 12, 2016 at 10:38 AM Jason Matusiak <address@hidden> wrote:
> Hi Marcus, The reason I went with sudo was because it was erroring out if I didn't:
> $ pip install -I --user pybombs
> Collecting pybombs
>   Using cached PyBOMBS-2.2.0.tar.gz
>     Complete output from command python setup.py egg_info:
> /usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'entry_points'
>       warnings.warn(msg)
> /usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'install_requires'
>       warnings.warn(msg)
>     usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
>        or: -c --help [cmd1 cmd2 ...]
>        or: -c --help-commands
>        or: -c cmd --help
>     error: invalid command 'egg_info'
>     ----------------------------------------
> Command "python setup.py egg_info" failed with error code 1 in 

I am still stuck at this stage. Assuming I am dead in the water, what is the next best (approved) way of installing GnuRadio?  Doing it by hand from the github clone?
Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]