[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] OOT Block on Windows (barely feasible?)

From: Geof Nieboer
Subject: Re: [Discuss-gnuradio] OOT Block on Windows (barely feasible?)
Date: Fri, 21 Oct 2016 21:54:38 -0400

Look in the cmake file(s) for something along the lines of:

If you find it, delete the double quotes.  I searched and found one in cmake\Modules\UseSWIG.cmake, so I would start there.


On Fri, Oct 21, 2016 at 9:20 PM, Imre Biacsics <address@hidden> wrote:
Dear specialists,

One step solved, creating two other issues. I'am sure: overlooking something very obvious. Sorry for that.
The two projects throw a "Error MSB6006 "cmd.exe" exited with code 9009."

Wich makes sense becease: 

'""' is not recognized as an internal or external command, operable program or batch file.

I hope someone can shine a light on this. Thanks in advance.

Imre Biacsics

Partial build output:

7>Target "CustomBuild" in file "C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.CppCommon.targets" from project "F:\grc\OOTmodules\gr-pager2\build\swig\_pager2_swig.vcxproj" (target "_BuildGenerateSourcesAction" depends on it):
7> Using "CustomBuild" task from assembly "C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.Build.CppTasks.Common.dll".
7> Task "CustomBuild"
7> Forcing rebuild of all source files due to missing command TLog "F:\grc\OOTmodules\gr-pager2\build\swig\_pager2_swig.dir\Debug\_pager2_swig.tlog\custombuild.command.1.tlog".
7> setlocal
7> "C:\Program Files (x86)\cmake\bin\cmake.exe" -HF:/grc/OOTmodules/gr-pager2 -BF:/grc/OOTmodules/gr-pager2/build --check-stamp-file F:\grc\OOTmodules\gr-pager2\build\swig\CMakeFiles\generate.stamp
7> if %errorlevel% neq 0 goto :cmEnd
7> :cmEnd
7> endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
7> :cmErrorLevel
7> exit /b %1
7> :cmDone
7> if %errorlevel% neq 0 goto :VCEnd
7> setlocal
7> ""
7> if %errorlevel% neq 0 goto :cmEnd
7> :cmEnd
7> endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
7> :cmErrorLevel
7> exit /b %1
7> :cmDone
7> if %errorlevel% neq 0 goto :VCEnd
7> setlocal
7> ""
7> if %errorlevel% neq 0 goto :cmEnd
7> :cmEnd
7> endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
7> :cmErrorLevel
7> exit /b %1
7> :cmDone
7> if %errorlevel% neq 0 goto :VCEnd
7> Building Custom Rule F:/grc/OOTmodules/gr-pager2/swig/CMakeLists.txt
7> CMake does not need to re-run because F:\grc\OOTmodules\gr-pager2\build\swig\CMakeFiles\generate.stamp is up-to-date.
7> '""' is not recognized as an internal or external command,
7> operable program or batch file.
7> 1>
7>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.CppCommon.targets(171,5): error MSB6006: "cmd.exe" exited with code 9009.
7> Done executing task "CustomBuild" -- FAILED.
7> 1>
7>Done building target "CustomBuild" in project "_pager2_swig.vcxproj" -- FAILED.
7>Build FAILED.
7>Time Elapsed 00:00:00.11
========== Rebuild All: 6 succeeded, 1 failed, 0 skipped ==========

On Wed, 19 Oct 2016 14:09:10 +0200, Geof Nieboer <address@hidden> wrote:


Glad you had success.  I'll work to replicate your steps, and then towards building a "developer pack" as an add-on to the basic install (to include adding all the many symbol files for debugging purposes).


On Wed, Oct 19, 2016 at 3:45 AM, Imre Biacsics <address@hidden> wrote:
I am going to answer my own question.

"How simple is the solution when the cause is known"

I was a bit dumb:

Somewhere in the scripts, spaces are removed. The result was that is looked for:


My real path :

F:/grc/OOT modules/

:( sorry

Imre Biacsics

(Swigwin issue)

Following up this message
With another question.

My goal was to sort out all the dependecies and paths to succesfully
automate the process.
When done I will share my findings.

In short, I did this:

- Installed Geof's win64 by msi, Cmake 3.3, VS2015 (community edition).
- Copied the dependecies from Geof's 'GNURadio_Windows_Build_Scripts'
after running it once: CppUnit, Boost, Swig, pkg-config.
- Used Gavin's tips to automate the gr-modtool New & Add functionality.
- Created a new terminal link, called: "Gnuradio modtool prompt",

    * The orginal "Gnuradio command prompt"
    * The the "vs 2015 win64 prompt".
    * Added path's for the dependecies statically. (For better control).

- Created .bat files for cmake & build.

(As example project I converted the gr-pager modules to OOT code)


1. Create OOT (MT_New.bat)
2. Add module 'pager2' (MT_Add.bat)
3. Insert converted pager code.
4. Cmake (CCmake.bat)
5. Build (Build.bat)

For readabillity i won't post the complete output, but step 4 gives me
some warnings (4x) i don't understand (Maybe linked to the error in step

CMake Warning (dev) at cmake/Modules/UseSWIG.cmake:300
   Link library type specifier "optimized" is followed by specifier "debug"
   instead of a library name.  The first specifier will be ignored.
Call Stack (most recent call first):
   cmake/Modules/GrSwig.cmake:174 (SWIG_LINK_LIBRARIES)
   swig/CMakeLists.txt:50 (GR_SWIG_MAKE)
This warning is for project developers.  Use -Wno-dev to suppress it.

But the result:

-- Configuring done
-- Generating done
-- Build files have been written to: F:/grc/OOT modules/gr-pager2/build

Step 5 produces 1 error:


building ZERO_CHECK => Succes
building gnuradio-pager2 => Succes!!!

building pager2_swig_swig_2d0df,
    is building _pager2_swig_swig_tag,
    is building pager2_swig_swig_doc,
    is building _pager2_swig_doc_tag  => Succes


CUSTOMBUILD : error : tag OUTPUT_DIRECTORY: Output directory
does not exist and cannot be created [F:\grc\OOT

That folder exists and is readable/writable (It holds a doxygen file and a
/xml subfolder), but following the naming conventions (These folders names
reflects the project names), something is wrong: there is no project named

Do not know how to fix this, but think it should be :

Okay.... so.... ignored it and inserted the .dll, .lib, block xml in GRC,
almost worked!
Blocks are visible and insertable, but starting the flowgraph is throws:

'module' object has no attribute <blockname>

Googling on that it's told "Your modules is not propery swigged", that
makes sense, given the errors.


Someone got clue to overcome this bump?

Thanks in Advance,

Imre Biacsics

Discuss-gnuradio mailing list

Using Opera's mail client: http://www.opera.com/mail/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]