[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Having Exact Same Problem: Fwd: [USRP-users] USRP X31

From: Collins, Richard
Subject: [Discuss-gnuradio] Having Exact Same Problem: Fwd: [USRP-users] USRP X310 with UBX-160 - transmit freezes with certain GNURadio flowgraphs
Date: Mon, 6 Feb 2017 16:58:46 -0500


I'm having what seems like the same problem as Jimmy reported in the USRP-Users back in November. (see forwarded portion of email, since I wasn't able to find any posts by him in discuss-gnuradio since then).

All I'm doing is generating continuous samples (fc32), that goes into a "Rational Resampler" block, and then directly into a UHD USRP Sink block. I'm using an X310 with UBX-160's as well.

When I don't use the UHD USRP Sink, but still have the Rational Resampler block, everything works fine. When I don't use the Rational Resampler block, but still send use the UHD USRP Sink block, everything works fine.

When i do use both in combination, the UHD Sink block does spit out a bunch of U's (maybe a couple lines worth) at the beginning of transmission, accepts about 3 seconds worth of items, and the stop requesting items. I see the flowgraph running, but nothing is moving (as can be seen by custom printf messages that say how much is being consumed and returned, or by using a QT GUI Sink, and seeing it stop). No errors are thrown, except that after I stop the flowgraph, one 'O' is thrown. That might not indicate anything, though.

Here's what I'm working with:
UHD 003.010.001.HEAD-0-gc705922a (tag "release_003_010_001_001")
GNU Radio v3.7.10.1-201-g884eddf4 (branch origin/maint)

Please let me know if more information is needed.

 -  Rich

---------- Forwarded message ----------
From: Jimmy Chau via USRP-users <address@hidden>
Date: Wed, Nov 9, 2016 at 9:15 PM
Subject: [USRP-users] USRP X310 with UBX-160 - transmit freezes with certain GNURadio flowgraphs
To: address@hidden


Using certain GNURadio flowgraphs (created in gnuradio-companion) with the USRP X310 and the UBX-160 daughter card, I’m encountering a problem where the radio stops transmitting, and signals/items seem to stop being generated/propagating through the flowgraph.  No error would appear when this happens (except sometimes, but not always, a burst of underflow “U” appearing all at once, shortly before before the transmit signal stops).

I’ve tried to narrow down the cause of this problem, and I’ve attached my simplest gnuradio-companion flowgraph (noise_mult1_tx.grc) that reliably triggers the problem within about 10 seconds.  This flowgraph consists of a Noise Source, attached to a Multiply Const (that multiples by 1), attached to the UHD USRP Sink.  I’ve also attached a QT GUI Sink to the input of the UHD USRP Sink to view the signal.

Eventually, the QT GUI Sink shows that the signal stops (i.e., stops updating), and if I use the RX2 input of the UBX-160 to receive the transmitted signal (through a SMA cable and a 20dB attenuator), the received signal would simply be the noise floor (i.e., no transmitted signal present).  However, the receiver would continue update.

I haven’t been able to figure out exactly what’s causing this problem.  If I remove the Multiply Const block (and connect the Noise Source directly) or if I replace the Noise Source with a Signal Source (a sine wave), the problem does not appear, and the transmitter works for as long as I let it run.

This problem would also appear if I try to add the outputs of two separate NBFM Transmit blocks (with a Rational Resampler), using an Add block, even without any Multiply Const block present.  The setup that causes this problem is arranged as:

[Signal Source] —> [NBFM Transmit] —> [Rational Resampler] —> [Add] —> [UHD USRP Sink]
[Signal Source] —> [NBFM Transmit] —> [Rational Resampler] —> [   ]

But it doesn’t appear if I try to feed only one NBFM signal into the UHD USRP Sink block.

I’ve tried reinstalling uhd and gnuradio using the latest commits from the "maint” branch (commit edfbbc from Nov 4 for gnuradio, but that did not seem to help.  I’m running GNURadio on Ubuntu 16.04.1 LTS.  UHD’s version string is:
linux; GNU C++ version 5.4.0 20160609; Boost_105800; UHD_003.010.001.000-1-g4594f7d7
The X310 also has a LFTX daughter card in slot B.

I’ve tried switching to another computer and removing all other USRPs from the gigabit Ethernet switch (so only the computer and the USRP X310 are connected).  However, this did not seem to resolve the problem.  Unfortunately, the computer and USRP are positioned so that it’s difficult to connect them without the switch in between, but I can try to connect them directly if it might help.

Any ideas on what the problem might be or suggestions on how to troubleshoot this?
I can provide additional examples if it would be helpful.

Thank you for any help!  And please let me know if my question would be better directed towards the discuss-gnuradio mailing list.

Best regards,

USRP-users mailing list

Attachment: noise_mult1_tx.grc
Description: Binary data

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]