[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] USRP N210 MIMO

From: Roohollah Parvizi
Subject: [Discuss-gnuradio] USRP N210 MIMO
Date: Tue, 14 Feb 2017 17:01:59 -0600

Hello all,

I am using the two USRP N210 with the SBX daughter board for the MIMO system. first, I changed the IP address of the second USRP to “ip-addrs=” and the name of both USRP’s as well.

I have these issues for setting the MIMO system,

·         I connected both USRP’s via the Netgear switch to the host computer. Unfortunately, I did not get any respond from the USRPs (none of them). I checked “uhd_find_devices” and the output was “ no USRP devices found “  Even I tried the single USRP using the switch I had the same issue.

·         After I was unsuccessful using the switch, I tested the MIMO cable without the switch (I mean I connected device 1 to the device 0 via the MIMO cable and then connected device 0 to the host computer), it worked. So, I started collecting the sample data using the “rx_samples_to_file_.exe” command. For getting sample data from both USRPs simultaneously I used the “ rx_samples_to_file --args=”addr=” --freq 1575.42e6 --gain 30 --rate 10e6  --duration 30  usrp_dir_G30_samples.dat  addr=  --freq 1575.42e6 --gain 30 --rate 10e6  --duration 30  usrp_reflect_G30__samples.dat “ ( the brief version of command ). However, it failed. Therefore, I executed those commands individually. Since I wanted to acquire signals simultaneously, I executed those commands separately at the different windows command prompt. My question is that is there any way to execute those commands as a block? Or is there a single command to force both USRP to start getting data?

Could you please help me with those issues?


Thanks in advance,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]