[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] AirSpy HF+ with GNU Radio and gr-osmosdr

From: Kyeong Su Shin
Subject: Re: [Discuss-gnuradio] AirSpy HF+ with GNU Radio and gr-osmosdr
Date: Mon, 24 Sep 2018 15:37:21 +0000

Hello Richard,

Did you try editing editing (or adding) udev rules and rebooting the system, or running GNU Radio as root (not recommended, but for testing purpose anyway)?

(I am not experienced with AirSpy HF+ dongles, but the udev rule would be something that I would suspect first in such situations.)


Kyeong Su Shin

보낸 사람: Richard Hedlund <address@hidden> 대신 Discuss-gnuradio <discuss-gnuradio-bounces+address@hidden>
보낸 날짜: 2018년 9월 24일 월요일 오후 8:35:50
받는 사람: address@hidden
제목: [Discuss-gnuradio] AirSpy HF+ with GNU Radio and gr-osmosdr

First of all, this is my first post on a mailing list and i apologize if this is the wrong place to ask this kind of question.

After having spent almost a full work week on getting the AirSpy HF+ to work with GNU Radio i thought it was time to post here. It feels like i have searched everywhere; different mailing lists, forums, AirSpy support along with their github and the web in general.

I have tried installing GNU Radio using pybombs following the guide:

I have tried installing GNU Radio following the guide by Alexandru Csete:

I have tried building and installing:

The AirSpy HF+ works with:
SDR# under Windows 10
GQRX under the Ubuntu system below

I does however not work with GNU Radio under Linux which is were i intend to use the HF+.

My system info (Dell Latitude 7480):
  • Ubuntu 18.04.1 LTS (full installation on a USB-stick)
  • 4.15.0-34-generic #37-Ubuntu SMP Mon Aug 27 15:21:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
  • 16 GB RAM
  • Intel Core i7 7600U
Output of: dmesg | grep usb
[ 7243.420121] usb 1-2: new high-speed USB device number 13 using xhci_hcd
[ 7243.569041] usb 1-2: New USB device found, idVendor=03eb, idProduct=800c
[ 7243.569052] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7243.569060] usb 1-2: Product: AIRSPY HF+
[ 7243.569067] usb 1-2: Manufacturer: www.airspy.com
[ 7243.569074] usb 1-2: SerialNumber: AIRSPYHF SN:3652A98094C73FA0

Output of: airspy_info
airspy_lib_version: 1.0.9
airspy_open() board 1 failed: AIRSPY_ERROR_NOT_FOUND (-5)

Running GNU Radio:
I try to run a simple flowgraph in GNU Radio with an osmocom source connected to a WX gui FFT sink. The output is the following:

Generating: '/home/hedric/top_block.py'

Executing: /usr/bin/python -u /home/hedric/top_block.py

Warning: failed to XInitThreads()
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

gr-osmosdr v0.1.x-xxx-xunknown (0.1.5git) gnuradio 3.7.11
built-in source types: file osmosdr fcd rtl rtl_tcp uhd plutosdr miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya freesrp
Traceback (most recent call last):
  File "/home/hedric/top_block.py", line 101, in <module>
  File "/home/hedric/top_block.py", line 95, in main
    tb = top_block_cls()
  File "/home/hedric/top_block.py", line 65, in __init__
    self.osmosdr_source_0 = osmosdr.source( args="numchan=" + str(1) + " " + 'airspy=0' )
  File "/usr/lib/python2.7/dist-packages/osmosdr/osmosdr_swig.py", line 1170, in make
    return _osmosdr_swig.source_make(*args, **kwargs)
RuntimeError: Failed to open AirSpy device (-5) AIRSPY_ERROR_NOT_FOUND

Hopefully this is enough information for you, if not please let me know. I am by no means an advanced Linux user but still eager to learn.

Kind regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]