[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Error compiling gnuradio v3.7.9

From: Ron Economos
Subject: Re: [Discuss-gnuradio] Error compiling gnuradio v3.7.9
Date: Thu, 4 Apr 2019 19:42:21 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1

I get the same error here. As it turns out, any version of GNU Radio before cannot be built with a newer CMake. If you really need to build 3.7.9, you have to use an older version of CMake.

I've tested CMake (the version used in Ubuntu 14.04), and that works.


On 4/4/19 17:24, Michael Dickens wrote:
Hmmm ... so the cmake debug output log shows:
/usr/bin/python2: can't open file '/home/user/workarea-gnuradio/gnuradio-3.7.9/gen/volk_compile_utils.py': [Errno 2] No such file or directory
Is this really true, that that file doesn't exist? Or maybe it needs to be "chmod a+x"?

On Thu, Apr 4, 2019, at 11:22 AM, address@hidden wrote:
I tried to solve the issues as in:
  1. I added SET(CMAKE_C_FLAGS "$(CMAKE_C_FLAGS) -lpthread") and SET(CMAKE_CXX_FLAGS "$(CMAKE_CXX_FLAGS) -lpthread") in CMakeLists.txt.
  2. I modified CMakeLists.txt of volk using "sed -i 's/(intrin.h/(x86intrin.h/g' ../volk/lib/CMakeLists.txt".
  3. I modified CMakeLists.txt of volk using "sed -i 's/.\+Werror=unused\-command-line\-argument.\+//g' ../volk/lib/CMakeLists.txt".
Now the output of cmake is:
and the content of CMakeError.log is:
Thank you.

Il 04.04.2019 17:04 address@hidden ha scritto:

Hi Michael,
I'm sorry! Sure, next time I will.
I'm building on Debian 9.8, and cmake is 3.7.2.
Thank you for reply.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]