[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Relink error starting gnuradio

From: Roger Brown
Subject: Relink error starting gnuradio
Date: Thu, 13 Feb 2020 22:33:44 -0700

I can't start gnuradio
$ gnuradio-companion 
/usr/bin/python3: Relink `/lib/x86_64-linux-gnu/libmount.so.1' with `/lib/x86_64-linux-gnu/librt.so.1' for IFUNC symbol `clock_gettime'
Segmentation fault (core dumped)

I installed it like this:
sudo add-apt-repository ppa:gnuradio/gnuradio-releases
sudo apt-get update
sudo apt install gnuradio

My environment:
$ whereis gnuradio-companion
gnuradio-companion: /usr/bin/gnuradio-companion /usr/share/man/man1/gnuradio-companion.1.gz
18.04.4 LTS (Bionic Beaver)
USRP B210 radio transceiver

I originally installed gnuradio from package repo. Then I built it from source. Then I also built it with pybombs. It worked fine until I uninstalled everything and tried to install it with the package ppa.

I suspect it's not technically a gnuradio problem, but it's manifesting there through python3. Any idea how to clean this up? I'm not experienced with python.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]