[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GNU Radio 3.8] Error loading modules on E310

From: Ivan Iudice
Subject: Re: [GNU Radio 3.8] Error loading modules on E310
Date: Fri, 21 Feb 2020 19:44:24 +0100

The version compiled and installed on the E310 is
As I stated in my last mail, I tried to compile my OOT module forcing cmake to use python 2.7 (see https://pastebin.com/EZfNkcGy), but it did not solve the problem.
An other question, why the same version of gnuradio ( I compiled and installed on my host machine uses python 3, and on the E310 uses python 2?


Il giorno 21 feb 2020, alle ore 19:25, Philip Balister <address@hidden> ha scritto:

What version gnuradio is installed on the E310?

$ gnuradio-config-info -v

There should be a cmake variable to set the python interpreter version.
That might be better than trying to point at libraries in the sdk.

Try -DPYTHON_EXECUTABLE=python (or path to python in the sdk)


On 2/21/20 11:54 AM, Ivan Iudice wrote:
How can I force canale to use python 2.7?
I tried configuring as in:
Cmake said that 3.5 is required, but finished configuring; anyway I compiled and installed, but nothing changed.


Il giorno 21 feb 2020, alle ore 16:22, Philip Balister <address@hidden> ha scritto:

On 2/21/20 3:21 AM, Ivan Iudice wrote:
Hi all,
gnuradio-companion calls the interpreter
#!/usr/bin/env python
Thus, the first python in the path is Python 2.7.
Is gnuradio using python 2.7?

Yes, try convincing cmake to use python2 for your OOT.



Il giorno 20 feb 2020, alle ore 20:51, Philip Balister <address@hidden> ha scritto:


$ less `which gnuradio-companion`

And see which python interpreter gnuradio-companion uses. Hopefully
someone from Ettus support knows for sure and can help with the OOT.

Your OOT looks like it is using python3


On 2/20/20 2:41 PM, Müller, Marcus (CEL) wrote:
Hi Ivan,

GNU Radio 3.7: Python2
GNU Radio 3.8: Py2 XOR Py3
GNU Radio >3.8: Py3
On Thu, 2020-02-20 at 19:35 +0100, Ivan Iudice wrote:
Your help is very welcome!
I’m sorry for the stupid question, however, how can I know which version of python is used by gnuradio?


Il giorno 20 feb 2020, alle ore 19:22, Philip Balister <address@hidden> ha scritto:

On 2/20/20 11:25 AM, Ivan Iudice wrote:
Hi Philip!
I only have site-package folder in both python2.7 and python3.5 lib folders, no dist-package.
The problem is that in python3.5/site-package there is not numpy, it’s only in python2.7/site-package.
Is it not installed for python3? How can I install it in both the sdk sysroot and in the target?

hmm, is gnuradio on the e310 using python 2 or 3? Maybe mixed python

Sorry for the short answer, trying to help, but I don't use the Ettus
builds for gnuradio.


Thanks so much.


Il giorno 20 feb 2020, alle ore 17:05, Philip Balister <address@hidden> ha scritto:

I had some dist-packages versus site-packages with some versions of
gnuradio. See if both exist. I'm betting numpy is in site-packages.


On 2/19/20 4:46 PM, Ivan Iudice wrote:
I’m curious to know if there is somebody in the list developing for E310 using current SDK.
This is a problem that, obviously, everybody wants execute custom module could incur.
Any ideas?


Il giorno 17 feb 2020, alle ore 17:31, address@hidden ha scritto:

Dear all,
finally I cross-compiled my OOT module for running on USRP E310.
Based on the instructions at "https://kb.ettus.com/Software_Development_on_the_E3xx_USRP_-_Building_RFNoC_UHD_/_GNU_Radio_/_gr-ettus_from_Source", I set the environment variable PYTHONPATH a little bit different, to point the path of the installed OOT module:

export PYTHONPATH=$LOCALPREFIX/lib/python3.5/dist-packages:$PYTHONPATH

Such a way, on the target I can load my custom module in python.
root@ni-e31x-316AFEA:~# python3 -c "import custom_mod"
I created a flowgraph that use my OOT module, and I discovered in the newer file system for E310 python3 has not all of the needed libraries.
root@ni-e31x-316AFEA:~# ./top_block.py
Traceback (most recent call last):
File "./top_block.py", line 12, in <module>
from gnuradio import blocks
File "/home/root/localinstall/usr/lib/python3.5/dist-packages/gnuradio/blocks/__init__.py", line 38, in <module>
from .stream_to_vector_decimator import *
File "/home/root/localinstall/usr/lib/python3.5/dist-packages/gnuradio/blocks/stream_to_vector_decimator.py", line 23, in <module>
from gnuradio import gr
File "/home/root/localinstall/usr/lib/python3.5/dist-packages/gnuradio/gr/__init__.py", line 46, in <module>
from .top_block import *
File "/home/root/localinstall/usr/lib/python3.5/dist-packages/gnuradio/gr/top_block.py", line 32, in <module>
from .hier_block2 import hier_block2
File "/home/root/localinstall/usr/lib/python3.5/dist-packages/gnuradio/gr/hier_block2.py", line 26, in <module>
import pmt
File "/home/root/localinstall/usr/lib/python3.5/dist-packages/pmt/__init__.py", line 61, in <module>
from .pmt_to_python import pmt_to_python as to_python
File "/home/root/localinstall/usr/lib/python3.5/dist-packages/pmt/pmt_to_python.py", line 23, in <module>
import numpy
ImportError: No module named 'numpy'
How could I solve the problem?
I'm so close to run my OOT modules on the target...
Thanks so much.

Con Tiscali Mobile Smart 30 4G hai minuti illimitati, 100 SMS e 30 Giga in 4G a soli 8,99€ al mese. http://tisca.li/smart30

reply via email to

[Prev in Thread] Current Thread [Next in Thread]