[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Ho to use Limesdr and rtl dongles with GNURadio 3.8.2

From: Josh
Subject: Re: Ho to use Limesdr and rtl dongles with GNURadio 3.8.2
Date: Fri, 4 Sep 2020 12:02:48 -0400

This is very lightly tested, but I have a PPA with some OOTs packaged (copied from Mait's debian packages) here: https://launchpad.net/~mormj/+archive/ubuntu/gnuradio-oot
if anyone is brave enough to give this a go

1) Install GNU Radio 3.8.2 from the gnuradio-releases PPA 
sudo add-apt-repository ppa:gnuradio/gnuradio-releases
sudo apt-get update
sudo apt install gnuradio

2) Install OOTs from gnuradio-oot PPA
sudo add-apt-repository ppa:mormj/gnuradio-oot
sudo apt-get update
sudo apt install gr-limesdr gr-osmocom gr-fcdproplus

Please let me know if this works for you.

On Thu, Sep 3, 2020 at 11:56 AM Bernd Schleicher <Bernd.Schleicher@qorvo.com> wrote:

Hi Paul and Christoph,


thanks for your posts. I have the same problem than Christoph. Fresh ubuntu 20.04 and tried to install GNU Radio and gqrx.


Based on your post, I installed GR3.8.1 and gqrx from ubuntu software app, but it does not find the RTL-SDR.


Do I need to install drivers for RTL (and USRP) devices? Could you tell me which installation should definitely work to test my hardware?


Thanks, Bernd



From: Discuss-gnuradio <discuss-gnuradio-bounces+bernd.schleicher=qorvo.com@gnu.org> On Behalf Of Christophe Seguinot
Sent: Montag, 31. August 2020 16:34
To: discuss-gnuradio@gnu.org
Subject: Re: Ho to use Limesdr and rtl dongles with GNURadio 3.8.2


**This email has been sent from an EXTERNAL source**

Thanks Paul

This in fact is an important information.

To resume I found that following packages installed from source under Ubuntu 20.04 (compiling some of them is tricky) are fully functionnal with GNURadio 3.8.2:

  • librtlsdr
  • gr-osmosdr
  • gr-limesdr (LimeSuite can be installed from ubuntu repository)
  • gqrx (if you want both GNU Radio AND gqrx)
  • gr-rds

For all these packages, installing from existing PPA (ubuntu and myriadrf repositories) breaks GNU Radio.


On 27/08/2020 12:44, Paul Boven wrote:

Hi Christophe,

This is unfortunately a known problem. The way GNU Radio was packaged in Ubuntu 20.04 is (to me) a bit odd, with the version number as part of the package name for most of the libraries.

If you install GR from the PPA, you will now get version 3.8.2, which is great. This will also include all the libraries. But if you then try to install a package from the regular Ubuntu repository, e.g. gr-osmosdr, this will pull in gnuradio-3.8.1 libraries. So now you end up with two versions of the gnuradio libraries installed on your system. Your gr-osmosdr (from the Ubuntu repositories) is linked against the 3.8.1 versions of the libraries, whereas the gnuradio on your system links against the 3.8.2 version of the libraries. Then, when you try to use the two together, mayhem ensues.

The result of this, is that the 3.8.2 on the PPA only works with itself, but not with the other packages from the regular Ubuntu LTS release. Unfortunately, the PPA is simply broken at this time.

Fixing this is not easy, because to solve the root cause, we'd have to figure out how to properly package GR for Ubuntu, and then convince Ubuntu to upgrade the version of GNU Radio (and all dependent packages!) that are part of the stable release.

Regards, Paul Boven.

On 8/27/20 12:25 PM, Christophe Seguinot wrote:


I recently switched my computer to Ubuntu 20.04 and installed GNURadio from ppa (http://ppa.launchpad.net/gnuradio/gnuradio-releases/ubuntu). Version 3.8.2 is the latest in this PPA and is installed by default.

I also installed gr-osmosdr gr-limesdr and gr-rds using sudo apt install.

Gnuradio is running fine in most cases. However, each time I run a flowgraph involving  SDR or LimeSDR Dongle I get the classical error:

     File "/home/-----/rds_rx.py", line 571, in __init__
         self.audio_sink_1 = audio.sink(audio_rate, '', True)
     AttributeError: 'int' object has no attribute 'sink'

Looking into library folder /usr/lib/x86_64-linux-gnu I found that some and 3.8.0 libraries are installed and probably conflicting with libraries. For example, command/ll libgnuradio-runtime*/ gives

     lrwxrwxrwx 1 root root      28 aug.  22 14:29 libgnuradio-runtime.so -> libgnuradio-runtime.so.3.8.2
     lrwxrwxrwx 1 root root      30 juil. 31 15:23 libgnuradio-runtime.so.3.8.1 -> libgnuradio-runtime.so.
     -rw-r--r-- 1 root root 1077632 juil. 31 15:23 libgnuradio-runtime.so.
     lrwxrwxrwx 1 root root      30 aug.  22 14:29 libgnuradio-runtime.so.3.8.2 -> libgnuradio-runtime.so.
     -rw-r--r-- 1 root root 1077632 aug.  22 14:29 libgnuradio-runtime.so.

It looks like 3.8.1 and 3.8.0 libraries have been installed when installing gr-osmosdr gr-limesdr and gr-rds

     installed libraries during gr-osmosdr install









     installed libraries during gr-rds install




I also notice that gr-osmosdr and gr-limesdr depend on libgnuradio-xxx  >= So I don't understand why 3.8.1 libraries have been installed after 3.8.2 libraries

Here are my questions:

  * Is the existence of these multiple libraries versions the cause of
  * Could someone please provide some link to PPA or source to compile
    (for gr-osmosdr and gr-limesdr) which are compatible with GNURadio
  * Should I reverse to GNURadio 3.8.1 using PPA

Regards, Christophe



This email may contain highly sensitive, confidential information that may be privileged and is meant only for the use of the specific intended addressee(s). Your receipt is not intended to waive any applicable privilege. If you have received this email in error, please delete it and immediately notify the sender by separate email. Unauthorized disclosure of confidential information may cause irreparable harm to Qorvo.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]