[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

OOT module and wrong symbolic link

From: Federico 'Larroca' La Rocca
Subject: OOT module and wrong symbolic link
Date: Mon, 22 Nov 2021 17:13:25 -0300

Hi everyone,

I'm currently porting an OOT module to 3.8 and stumbled into a weird situation regarding the .so files that are installed on /usr/local/lib/x86_64-linux-gnu/. If I understood correctly, there are three files that are created there (files reflect my OOT's name): libgnuradio-isdbt.so, libgnuradio-isdbt.so.1.0.0git and libgnuradio-isdbt.so.XXX (where XXX is related to the commit's short id; for instance now I have libgnuradio-isdbt.so.17e304df). The first two files are actually symbolic links: libgnuradio-isdbt.so points to libgnuradio-isdbt.so.1.0.0git which in turn points to libgnuradio-isdbt.so.XXX.

I was not very careful when (un)installling my OOT, so I got three or four versions of libgnuradio-isdbt.so.XXX in /usr/local/lib/x86_64-linux-gnu/. The problem was that the file libgnuradio-isdbt.so.1.0.0git stubbornly pointed to the wrong (old) version of libgnuradio-isdbt.so.XXX. This resulted in a really difficult to diagnose error, as the OOT worked on a Docker, but I repeatedly got an "AttributeError: module ..." error on my installation.

The problem was solved by deleting the old libgnuradio-isdbt.so.XXX files. The question I have is then: why was the second symbolic link pointing to an older version of the .so file? Maybe someone can point me to the cmake file that creates and copies these files.

best and thanks in advance

reply via email to

[Prev in Thread] Current Thread [Next in Thread]