discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling gnustep-base-1.5.0 with OpenBSD3.1


From: David Wetzel
Subject: Re: Compiling gnustep-base-1.5.0 with OpenBSD3.1
Date: Sat, 21 Sep 2002 03:01:04 +0200

Hi,

that is how you can build GS on NetBSD 1.6:


cd /usr/lib
                        ar -dv libobjc_p.a      NXConstStr.po
                        ar -dv libobjc_pic.a    NXConstStr.so
                        ar -dv libobjc.a        NXConstStr.o

rm libobjc.so.1*

cd core/make/
./configure --prefix=/usr/GNUstep

gmake
su
gmake install

cd ../base/
source /usr/GNUstep/System/Makefiles/GNUstep.csh
./configure --prefix=/usr/GNUstep

gmake
su
gmake install

cd ../gui
./configure --prefix=/usr/GNUstep
gmake

etc...

The needed libs like ffcall and libxml2 are installed via pkgsources.
OpenBSD is a spinoff of NetBSD. You may have luck with the same settings?

And this was from CVS if that matters.

Good Luck

Dave

---
   _  _
 _(_)(_)_  David Wetzel, Turbocat's Development,
(_) __ (_) Buchhorster Strasse 23, D-16567 Muehlenbeck/Berlin, FRG,
  _/  \_   Fax +49 33056 82835 Phone +49 33056 82834
 (______)  http://www.turbocat.de/  address@hidden





reply via email to

[Prev in Thread] Current Thread [Next in Thread]