[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep apps segfault on startup with Debian packages

From: Adam Fedor
Subject: Re: GNUstep apps segfault on startup with Debian packages
Date: Sun, 24 Nov 2002 20:47:10 -0700
User-agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.1) Gecko/20020905

These are all very odd problems. Is it possible to get a gdb backtrace? You can go

debugapp MyApp.app
> run
> bt

And your path should include $GNUSTEP_SYSTEM_ROOT/Tools/ ix86/linux-gnu/gnu-gnu-gnu/gpbs, unless GNUstep.sh is not getting sourced. Or unless you have a very old version of GNUstep installed.

Jim Balhoff wrote:
Thanks for the suggestion - I didn't have my .xinitrc configured (but this hasn't stopped GNUstep in my previous setup - I just let the first app start it up). So I used the file from the buildguide. I had to put a link from $GNUSTEP_SYSTEM_ROOT/Tools/gpbs to $GNUSTEP_SYSTEM_ROOT/Tools/ ix86/linux-gnu/gnu-gnu-gnu/gpbs for gpbs to be found. But anyway, starting gpbs results in "Segmentation fault" as well. Another weird thing is that all the "defaults write" commands produce "defaults write: domain is not a dictionary!"

Thanks - still not working,

On Sunday, November 24, 2002, at 06:13 PM, Jim McLoughlin wrote:

Hi there

My guess is that you did not configure your .xinitrc file to start the pasteboard server on X startup. When installing the debian packages, it still helps to follow the build guide located at http://documents.made-it.com/GNUstep/Build. You should look at section 6, which covers post install configuration.

The debian installers should handle section 6.1 (starting gdomap and gdnc), but you should configure the .xinitrc as in section 6.3 (linked to here: http://documents.made-it.com/GNUstep/Build/xinitrc). Thsi .xinitrc will also handle setting your defaults (described in section 6.2).

I recall seeing segfault before I did the above, so hopefully this will solve your problem.

jim M

On Monday, November 25, 2002, at 05:51 AM, Jim Balhoff wrote:


Is anyone using the compiled GNUstep packages available for Debian? I decided to try Debian a few days ago after seeing that I could just use apt-get to install GNUstep. Everything else is working fine, but trying to launch any GNUstep app just produces "Segmentation fault." I at first tried Debian "stable", and nothing worked. So I upgraded my whole system to "unstable" to get the newer packages (make/base 1.5.0, gui/back 0.8.1). Still a no-go. I've tried the Debian packages for some apps as well as compiled some myself - same result. I don't want to build my own GNUstep libraries - since I switched to Debian so I could have GNUstep integrated into the rest of my package management (and building GNUstep takes a while on my old laptop).

Anyone got it working?


P.S. Maybe this is more of a Debian question, but I thought I'd find some others with this setup here.

Discuss-gnustep mailing list

Adam Fedor, Digital Optics Corp.      | I'm glad I hate spinach, because
http://www.doc.com                    | if I didn't, I'd eat it, and you
                                      | know how I hate the stuff.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]