discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling from scratch.


From: Adam Fedor
Subject: Re: Compiling from scratch.
Date: Sat, 25 Oct 2003 20:11:39 -0600


Second problem, it simply does not work. See attached log.

It fails over-all because -base cannot be compiled (and installed) due
to a missing ffcall and/or libffi installation.

The fact is that ffcall 1.8d IS installed:

address@hidden ffcall-1.8d]$ ls -l /usr/local/lib/lib*{call,tramp}*
-rw-r--r--    1     2288 Oct 25 07:32 /usr/local/lib/libavcall.a
-rw-r--r--    1      438 Oct 25 07:32 /usr/local/lib/libavcall.la
-rw-r--r--    1     5304 Oct 25 07:32 /usr/local/lib/libcallback.a
-rw-r--r--    1      444 Oct 25 07:32 /usr/local/lib/libcallback.la
-rw-r--r--    1     1726 Oct 25 07:32 /usr/local/lib/libtrampoline.a
-rw-r--r--    1     3722 Oct 25 07:32 /usr/local/lib/libvacall.a




Yes you do have ffcall. It says so in the log file. But you don't have a proper libobjc library:

checking for callback.h... yes
checking "for forwarding callback in runtime"... no
checking "FFI library usage"... none

GNUstep requires ffcall or libffi and proper libobjc hooks to do
-----------------------------
invocations and DO.
Make sure one of these libraries is installed and you have a proper
libobjc library. Otherwise DO will not be compatible with other


(underlines are mine).





reply via email to

[Prev in Thread] Current Thread [Next in Thread]