[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

objc-load error: TLS

From: Jonathan Hepburn
Subject: objc-load error: TLS
Date: Tue, 6 Jan 2004 21:41:25 +1100
User-agent: Mutt/1.5.4i

Now I am very, VERY, annoyed.

Having spent ten minutes writing a carefully detailed email about an
error that was causing a total and utter failure to run any GNUStep
application (I use rather a lot, so this was a very annoying problem), I
tried something silly and drastic and it WORKED.


If anyone is using fairly recent NVidia graphics drivers (4*** or 5***)
combined with a fairly recent (for e.g. RH9 or Debian Sid/Testing)
libc6/glibc and gets the following error: 'objc-load:libGL.so.1 cannot
handle TLS data'

The solution is to delete the /usr/lib/tls directory entirely. All it
contains is NVidia libraries that aren't necessary (I would check this
before doing any deletion: maybe move to tls.bk or something, or just
delete the libGL* links and files) and break when combined with this
particular libc6.

I hope this helps someone else.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]