[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Q] Loading GNUstep Shared Object in Plain C Problem

From: NeXT
Subject: [Q] Loading GNUstep Shared Object in Plain C Problem
Date: Wed, 07 Jan 2004 16:23:20 +0900


I'm currently creating NSS (Name Service Switch) module using GNUstep in Linux. For who does not know NSS, NSS is a something like system directory information system. For example using NSS, I can add more data source for user account information like passwd and shadow in addition to file database
like /etc/passwd and /etc/shadow.

The module works when I run "getent passwd edisuser" but when I run "su edisuser" it just waits on;

This is "strace su edisuser"
fcntl64(4, F_SETLKW, {type=F_UNLCK, whence=SEEK_SET, start=0, len=0}) = 0
alarm(0)                                = 1
rt_sigaction(SIGALRM, {SIG_DFL}, NULL, 8) = 0
close(4)                                = 0
brk(0)                                  = 0x80b8000
brk(0x80ba000)                          = 0x80ba000
time([1073459479])                      = 1073459479
open("/etc/localtime", O_RDONLY)        = 4
fstat64(4, {st_mode=S_IFREG|0644, st_size=152, ...}) = 0
mmap2(NULL, 131072, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40815000 read(4, "TZif\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\5\0\0\0\5\0"..., 131072) = 152
close(4)                                = 0
munmap(0x40815000, 131072)              = 0
getpid()                                = 22686
rt_sigprocmask(SIG_SETMASK, NULL, [RTMIN], 8) = 0
rt_sigsuspend([] <unfinished ...>

What should I do for this ? I think this is related to pthread system. because after removing all Objective-C part, and link shared object with all library except pthread it does work well. But as you know, if I use Objective-C, I should link pthread and it does show the above result.

Thanks in advance.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]