[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: kvm problem with FreeBSD

From: Stefan Kleine Stegemann
Subject: Re: kvm problem with FreeBSD
Date: Tue, 17 Aug 2004 21:53:39 +0200


I can write a little test program when i'm at home. As mentioned before, the problem occured after i updated gnustep from cvs last night. I disabled
kvm and now it works, what makes me wondering. I guess the proc system
is used when kvm is not used? Seems somewhat strange to me.

I finally wrote a little program to check if kvm works on my FreeBSD box (see attached file) outside the GNUstep context. I does not. Regardless what i tried, I got the well-known error message 'kvmtest: cannot open /proc/30888/mem' whenever kvm_getenvv was called. So I looked into the libkvm source code and
found the following line of code in the function kvm_uread:
sprintf(procfile, "/proc/%d/mem", kp->ki_pid)
kvm_uread is invoked indirectly by kvm_getenvv.

Grmpflz. Seems like kvm (at least the kvm_getenvv function) cannot work without the proc filesystem. As mentioned earlier, I've disabled proc-fs on my box because
it has been suggested in the installation instructions.

The only way that seems to work for me is not to use libkvm on FreeBSD systems without proc-fs support. I disabled kvm usage by hacking the configure script and GNUstep works again. Can we add a flag like --without-kvm to configure in



Attachment: kvmtest.c
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]