discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep themeing and MacOS HITheme APIs...


From: M. Uli Kusterer
Subject: Re: GNUstep themeing and MacOS HITheme APIs...
Date: Fri, 05 Nov 2004 23:50:48 +0100
User-agent: MT-NewsWatcher/3.4 (PPC Mac OS X)

In article <mailman.981.1099690170.8225.discuss-gnustep@gnu.org>,
 Michael Hanni <mhanni@yahoo.com> wrote:

> The latest NSTabView code
> (http://www.cc.utah.edu/~msh3/gnustep/NSTabView-NG-0.02.tgz) has methods to
> draw the whole tab and for each side of the tab. In theory you could override
> easily any of these methods to completely change the look of the tab.

 Any chance of moving that into GSDrawFunctions? From what I understand, 
this is the recommended place for collecting drawing functions that need 
to be replaced when themeing.

 Hmmm... thinking of switching themes at runtime there: Shouldn't 
GSDrawFunctions be made a singleton with all those methods being 
instance methods instead of class methods? Then we could have:

   +(id) currentDrawFunctions;

which would give us the GSDrawFunctions object for the current theme, and

   -(void)  set;

to make a particular instance (or subclass) of GSDrawFunctions the 
current theme that is returned by currentDrawFunctions.

Oh, and is there any reason why GSDrawFunctions has unnamed parameters 
as in

   +(NSRect) drawButton: (NSRect)border : (NSRect)clip;

? Wouldn't

   +(NSRect) drawButton: (NSRect)border clipTo: (NSRect)clip;

be more readable? I spent the first half minute looking for the "?" to 
go with that standalone ":"...

Cheers,
-- Uli
http://www.zathras.de


reply via email to

[Prev in Thread] Current Thread [Next in Thread]