[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

MSWindows CVS install problem [was :Frameworks under MS Windows and link

From: Marc Brünink
Subject: MSWindows CVS install problem [was :Frameworks under MS Windows and linking issues]
Date: Mon, 21 Mar 2005 20:44:51 +0100

On Friday, Mar 18, 2005, at 18:20 Europe/Berlin, Nicola Pero wrote:

gcc        -o shared_obj/FBConnWin.exe \
         ./shared_obj/FBConnWin_main.o \

-Lc:/GNUstep/Library/Libraries -Lc:/GNUstep/Local/Library/Libraries
-Lc:/GNUstep/System/Library/Libraries -lSRFoundation -lgnustep-base
-lobjc -lws2_32 -ladvapi32 -lcomctl32 -luser32 -lcomdlg32 -lmpr
-lnetapi32 -lm -I.
./shared_obj/FBConnWin_main.o(.data+0x398):FBConnWin_main.m: undefined
reference to `__objc_class_name_SRConnection'
make[1]: *** [shared_obj/FBConnWin.exe] Error 1
make: *** [FBConnWin.all.tool.variables] Error 2

gnustep-base and gnustep-gui and so on always consist out of two
a libgnustep-base.a and a gnustep-base.dll. A compilation of my
framework results in just one .dll. Don't know if this is somehow
related. Actually the only thing I know is: This error drives me mad!
And the other thing: Burn Windows boxes, burn.

But back on topic:
Is there a "How-to compile frameworks (under Windows)"? I need one!

Frameworks are not supported (yet) under Windows, so I'm not surprised it
doesn't work for you.

I'll have a look at it in a few days or weeks.  Maybe tonight. :)

hm. Libraries should work? Actually they don't work for me. I got the
same error. At least I a got a (non-working) libSRFoundation.a.

Yes - libraries should work. They work for me. I assume you're using CVS
obviously ;-)

If they don't work for you, please make sure you're using CVS and
msys/mingw with the version/explanation I posted recently to the list.

Actually I did not use CVS but the binary installer. Anyway, I tried to install the current CVS following your instructions. After some smaller problems I somehow managed a clean install. But now I always get critical errors while running an examples/gui app. The very bad thing about these errors: The critical-error-window is just black! Further there are no error messages on console until i close the critical-error-window. Then I got the following:

The file 'c:\Programme\GNUstep\GNUstep\System\.GNUsteprc' is writable by someone other than its owner.
Ignoring it.
c:\Projects\gnustep-cvs\usr- apps\examples\gui\GFractal\GFractal.app\GFractal.exe: Uncaught exception NSRangeException, reason: Index 0 is out of range 0 (in 'objectAtIndex:')

Does someone have a clue?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]