discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: (Windows) has anyone successfully ship a product build on GNUstep?


From: Lloyd Dupont
Subject: Re: (Windows) has anyone successfully ship a product build on GNUstep?
Date: Tue, 13 Sep 2005 17:45:46 +1000

I don't know Richard, it's kind of weird.
When I was testing my command line test,
the file C:\GNUstep\Defaults\.GNUstepDefaults
(and the directory hierarchy above it) was created.

But... now that I have everything sorted out, I ran my (working now) installer on a newly formatted/installed XP computer and no such file was created.
(maybe because of the newly added resource to my project?)

While I was reading the code I had the feeling this path was absolutely not changeable. I tried to set the GNUSTEP_USER_ROOT environment value to some other directory, but that didn't work :-/

So the question is:
how to set-up the place where the default would be read?
(not too mention idealy I would like them to point to
C:\Documents and Settings\<User Name>\Application Data\GNUstep\.GNUstepDefaults


----- Original Message ----- From: "Richard Frith-Macdonald" <address@hidden>
To: <address@hidden>
Sent: Tuesday, September 13, 2005 4:51 PM
Subject: Re: (Windows) has anyone successfully ship a product build on GNUstep?


On 2005-09-13 06:27:29 +0100 Lloyd Dupont <address@hidden> wrote:

Curiously my GNUstep product works well on my computer.
I build a new test machine (with a newly formatted WindowsXP install) and it just doesn't work (crash when I call [NSColor whiteColor])

As a matter of test I 'installed' GNUstep with the old GNUstep installer.
And while I was able to run a program from the MSys command line if I try to run it from dos (equivalent to the users clicking the program's icon) it fails to run.

Beside when I looked into NSPathUtilites I see that 'GNUstep' is hard coded, that might be the reason why, after successfully ruun from the command line a new GNUstep directory is created on C:. This is not acceptable and I try to fix it by setting all environment variables which seems appropriate, but non of them fixed the problem :-(

I'm moderately sure that nothing is hard-coded in the sense of being fixed so it can't be overridden. Default values have to be in the code ... but everything should be overridable.
Can you be more specific?



_______________________________________________
Discuss-gnustep mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/discuss-gnustep





reply via email to

[Prev in Thread] Current Thread [Next in Thread]