[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

NSPortMessage problem

From: Thierry DELHAISE
Subject: NSPortMessage problem
Date: Wed, 14 Sep 2005 00:48:08 +0200

Hi, all

With a CVS checkout dated from two days, I've problem with a Daemon built on top of GNUstep-base.

In my application I've two threads : the two have in their -init method a construct of an [NSPortMessage port]. Dynamicaly (I mean without using NSConnection and NSProxy), I construct an NSMessagePort init with the two ports . Then I send the message to the other thread. The first thread said that it successfully post the message. The second never receive the message : my -handlePortMessage never get called inside the running thread. In the +startThread method I've the registration of the port thread inside the runLoop, and later I run [[NSRunLoop currentRunLoop] run ]. I join the code below of the two threads.

Any advice on this .

Some precisions. I use NSMessagePort directly witout NSConnection and NSProxy beacause of a choice design : I want the only "protocol" known for the two threads are NSPortMessage.

I can assure that when I run my code I can see the two Unix socket created by GNUstep for each ports.

So what am I doing wrong ?

thx in advance.



The Thread sending is FastServer.m
The thread receiving is FastNetworkManager.m
This last one never receive the Message.

Attachment: FastNetworkManager.m
Description: Binary data

Attachment: FastServer.m
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]