discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building GWorkspace on Solaris 10


From: Enrico Sersale
Subject: Re: Building GWorkspace on Solaris 10
Date: Mon, 26 Jun 2006 13:24:38 +0300

On 2006-06-25 16:05:24 +0300 Chris Vetter <address@hidden> wrote:

On 2006-06-25 14:59:46 +0200 Chris Vetter <address@hidden> wrote:
dunno where else to post this to...
On Solaris 10, GWorkspace fails to build Tools 'mdextractor' and 'ddbd' due to "symbol belongs to implicit dependency" errors. To fix this, the path to SQLite3 and -lsqlite3 need to be set in each respective GNUmakefile.preamble's ADDITIONAL_LDFLAGS. Simply refering to GWorkspace's own SQLite isn't enough.

I've fixed this.

Sorry, I forgot to mention two things:

1) GWorkspace apparently works with SQLite3 version 3002002 -- though configure is looking for 3002008

With 3002002 some tools (actually not active as gmds and mdextractor), don't 
work. But this is not a problem for ddbd (file annotations, lsfolders and, in 
the future, thumbnails and/or other things).
Anyway, I've changed the required version to 3002006.

2) When you start GWorkspace, the 'GWorkspace' (main) menu entry doesn't have a title (it's still usable, though).

Here... I don't know. Do you have this problem with other applications too?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]