discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: trying to debug problems with NSAutoreleasepool


From: Richard Frith-Macdonald
Subject: Re: trying to debug problems with NSAutoreleasepool
Date: Tue, 27 Nov 2007 14:29:47 +0000
User-agent: GNUMail (Version 1.2.0)

On 2007-11-27 14:01:43 +0000 "Sebastian Reitenbach" <address@hidden> wrote:

Hi,

I try to figure out how that NSAutoreleasepool is working, because I want to debug some problems I have there while trying to get opengroupware to run on gnustep-base. The webui application breaks in a lot of places in NSAutoreleasepool.m:405
here the backtrace:

<snipped reasonable looking trace (though line numbers make it look like it's not a current version of gnustep)>

I added a NSLog statement before that in the while loop in -emptyPool, but that ended up in an endless loop, eating up all my stack frames.

Sure ... NSLog autoreleases things ... likely to cause difficulties in the middle of emptying the current pool.

in LSLoginAccountCommand.m, and in the other places where it runs into that exception, the NSAutoreleasepool seems to be handled like in other applications that work well.

What exception?

Any idea what could be my problem or how I could try to figure out?

You didn't say what your problem was ... the stacktrace looked like a normal emptying of a pool. Perhaps you have objects in the poolthat are crashing when they are released?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]