[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

MacPort GNUstep modules - how to include in CMAKE ?

From: Juergen Lorenz Simon
Subject: MacPort GNUstep modules - how to include in CMAKE ?
Date: Mon, 24 Aug 2009 18:00:43 +0200


this might not be the exact right place for this question, but perhaps someone has run into the same trouble.

I'm a little lost in the woods here and need some help. I would like to use the GDL2 with a custom EOAdaptor I've been implementing for PostGIS, using the PostgreSQL adaptor that came with gdl2 as a template. Since I needed to compile the sourcecode for that, I found myself in the crutch of having to compile GNUstep on OSX. I had some experience with that from a few years back and expected a nightmare. I was not disappointed.

Checking out GNUstep from svn and building it on OS X 10.5. out of the box just failed. Next I tried to install GNUstep using the macports version. At first that failed as well, due to some header inclusion problems with Gorm, but that seems to have been fixed to some extend. So I ended up with an installation in /opt/local/GNUstep. 

Next I checked out the gdl2 sources from SVN, imported the GNUstep.sh from /opt/local/GNUstep and was able to compile the PostgreSQL adaptor variant for PostGIS. 

Finally I want to use the EOControl and EOAccess libraries as well as the PostGISEOAdaptor I created in a project, which so far has been set up using cmake. The problem I have now, is that cmake seems to run fine with the references to the GNUstep libs in /opt/local. However, the compiler seems not to get it. I tried using the compiler used by macports:

cmake -DCMAKE_CXX_COMPILER=/opt/local/bin/g++-mp-4.2 -DCMAKE_C_COMPILER=/opt/local/bin/gcc-mp-4.2 

which cmake took without problems. However, during compile time, I get errors of this type:

In file included from /opt/local/GNUstep/Local/Library/Headers/Foundation/NSObjCRuntime.h:32,
                 from /opt/local/GNUstep/Local/Library/Headers/Foundation/NSObject.h:31,
                 from /opt/local/GNUstep/Local/Library/Headers/Foundation/FoundationErrors.h:29,
                 from /opt/local/GNUstep/Local/Library/Headers/Foundation/Foundation.h:33,
                 from /Users/simon/Projects/webtecc/iDry/workspace_c/sartre/include/Sartre/Filters/ContrastEnhancer.h:10,
                 from /Users/simon/Projects/webtecc/iDry/workspace_c/sartre/src/Filters/ContrastEnhancer.mm:13:
/opt/local/GNUstep/Local/Library/Headers/GNUstepBase/preface.h:77:28: error: objc/encoding.h: No such file or directory
/opt/local/GNUstep/Local/Library/Headers/GNUstepBase/preface.h:78:26: error: objc/sarray.h: No such file or directory

It seems to me, like the gcc compiler does not look in the right places for the Objective-C related header files. Does anyone here know, how I can tell the compiler where to look? I tried looking at --sysroot, but so far unsuccessful. 

Any pointers are greatly appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]