discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ANN: GNUstep 2.6.0 for openSUSE 11.4


From: Matt Rice
Subject: Re: ANN: GNUstep 2.6.0 for openSUSE 11.4
Date: Tue, 14 Jun 2011 00:46:06 -0700

On Mon, Jun 13, 2011 at 3:33 PM, David Chisnall <address@hidden> wrote:
> On 13 Jun 2011, at 23:01, Nat! wrote:
>
>> o     the standard gdb doesn't seem so clued in about objective-c, but I 
>> don't see a specific gdb package for objective-c. Where to get it ?
>
>
> Did you try 'set language objective-c'?  I think gdb has Objective-C support 
> by default, but sometimes it decides that you're in a C or C++ stack frame 
> randomly and sets the language wrongly.

what version of gdb?
when apple applied this patch to gcc
http://gcc.gnu.org/ml/gcc-patches/2006-03/msg01515.html
they never bothered to update gdb to recognize the DW_LANG_ObjC,
this should have been fixed in gdb 6.8 released 4 years ago,
but I still often see backtraces on this list where this bug is apparent.

probably because the bug was introduced before the switch to gplv3 and
fixed after.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]