discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Did not find correct version of backend (libgnustep-back-024.bundle),


From: Edwin Ancaer
Subject: Did not find correct version of backend (libgnustep-back-024.bundle),
Date: Mon, 15 Sep 2014 22:37:58 +0200

I downloaded the following gnustep modules:
gnustep-back-0.24.0
gnustep-base-1.24.6
gnustep-gui-0.24.0
gnustep-make-2.6.6

and installed them with clang 3.5

In tests.log for GUI, all tests were reported as passed (some hopes were dashed)

When trying to run a simple HelloWorld application, I got the following message:

address@hidden ~/FirstCocoa $ openapp ./HelloWorld.app
2014-09-15 20:45:06.992 HelloWorld[9482] Did not find correct version of backend (libgnustep-back-024.bundle), falling back to std (libgnustep-back.bundle).
2014-09-15 20:45:06.998 HelloWorld[9482] NSApplication.m:304  Assertion failed in BOOL initialize_gnustep_backend().  Unable to find backend back
/home/edwin/FirstCocoa/HelloWorld.app/HelloWorld: Uncaught exception NSInternalInconsistencyException, reason: NSApplication.m:304  Assertion failed in BOOL initialize_gnustep_backend().  Unable to find backend back
Aborted

I verified and found the file lignustep-back-024.bundle.
Any idea what has gone wrong?  Some months ago I installed the same modules (gnustep stable version) on another machine without problems.

Kind regards, and thanks for any help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]