discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GSspell on Windows


From: Wolfgang Lux
Subject: Re: GSspell on Windows
Date: Mon, 6 Jul 2015 22:41:34 +0200

> Am 04.07.2015 um 10:04 schrieb Germán Arias <address@hidden>:
> 
> El jue, 02-07-2015 a las 10:32 +0200, Wolfgang Lux escribió:
>>> Am 02.07.2015 um 08:11 schrieb Germán Arias <address@hidden>:
>>> 
>>> I forgot say that I run make_services before each test, but this don't
>>> makes any difference.
>>> 
>>> Germán
>>> 
>>> El jue, 02-07-2015 a las 00:02 -0600, Germán Arias escribió:
>>>> I simply can't make to work the GSspell service on Windows. I have
>>>> installed the English and Spanish dictionaries, if I run "aspell dump
>>>> dicts" on the shell all the available dictionaries are listed. The
>>>> GSspell service runs only with AmericanEnglish, even when aspell.h is
>>>> present and HAVE_ASPELL_H is defined to 1. However when use Ink and try
>>>> to use the spell checker (Spanish) I get:
>>>> 
>>>> [New Thread 3672.0xa84]
>>>> warning: 2015-07-01 19:18:54.444 Ink[3672:2380] Language: Spanish
>>>> warning: 2015-07-01 19:18:54.514 Ink[3672:2380] Service to start: (null)
>>>> warning: 2015-07-01 19:18:54.534 Ink[3672:2380] Port: (null)
>>>> warning: 2015-07-01 19:18:54.564 Ink[3672:2380] Failed to contact spell
>>>> checker
>>>> for language 'Spanish'
>>>> warning: 2015-07-01 19:18:54.584 Ink[3672:2380] Failed to get the
>>>> spellserver
>>>> [Inferior 1 (process 3672) exited normally]
>>>> (gdb)
>>>> 
>>>> 
>>>> Any idea about what is going wrong here?
>> 
>> There isn't much going wrong here. I think nobody ever got around to 
>> implement auto-detection of the available dictionaries, so the GSspell 
>> service assumes only the AmericanEnglish dictionary is present by default. 
>> The client side on the other hand (Ink in your example) tries to connect to 
>> the spell service using your current default language and GSspell then 
>> responds that this language is not available. If you have other language 
>> dictionaries besides American English installed on your system, you can 
>> manually update the supported languages by updating the NSLanguages property 
>> in the Info-gnustep.plist file of GSspell.service (and eventually restarting 
>> the spell service if it is currently running.
>> 
>> Wolfgang
>> 
> 
> Thanks. Now the GSspell service starts correctly with the corresponding
> language. Now the problem is that Ink can't connect with the
> service :-( I will investigate this later.

Actually I was wrong. I just had a look at the GSspell server code and it looks 
like I got around to implementing the language detection code. To support 
languages besides the default (American English) the server maintains a little 
bundle in the $GNUSTEP_USER_DOMAIN/Library/Services directory that declares all 
languages supported by the spell server. Each time the spell server is started 
it will update the list of languages in this bundle, so you should see the list 
of available languages on your system after you have connected to the spell 
server at least once. If that doesn't work, there is some other problem with 
your installation. Has aspell been properly detected during the configuration 
of gnustep-gui? If the aspell headers were not found during configuration only 
a dummy spell checker is built, which understands only American English.

Wolfgang




reply via email to

[Prev in Thread] Current Thread [Next in Thread]