[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug in latest Recycler.app ?

From: Riccardo Mottola
Subject: Re: Bug in latest Recycler.app ?
Date: Sat, 27 Feb 2016 19:29:16 +0100
User-agent: Mozilla/5.0 (Windows NT 6.0; rv:42.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39


Bertrand Dekoninck ha scritto:
Ricardo is on his way moving some methods from GWorkspace/FSNode into Gui, so that they could be used by others apps.
They concern mounting/unmounting devices.

The changes reflect mounting unmounting methods and various tricks to know about mounted volumes. However I did not change anything particular in the Recycler logic about standard files nor anything between the connections.

Since I few days, testing this, I've remarked that my Recycler.app seems to be broken : it constantly has a FullRecycler icon, and I can't drag a file on it, without being hit by an Alert saying : "Cannot contact GWorkspace".

I'm not totally sure it's not a local problem of my installs. I've tried on both ppc and x86 without more luck.

Nethertheless on a laptop of mine running an older revision (late december), the bug isn't present.

On GWorkspace's startup, I've also an error message on one computer in the console saying :

"2016-02-24 19:36:41.523 GWorkspace[21999] No handle for event rport on descriptor 21"

I'm not sure it's related to this.

Can anyone reproduce this ?

I tried on two computers, the recycler icon is correct, be ti full or not. I also tried adding and removing files form the trash as well a quitting and restarting GWorkspace to see if the Trash status is recalculated and it is.

Caution : latest svn GWorkspace must be compiled with latest gui.
I think it may compile against older stuff, but I expect unmonuting and mounting not to work cleanly in that case.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]