[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs Anyone?

From: Riccardo Mottola
Subject: Re: Emacs Anyone?
Date: Wed, 1 Mar 2017 20:10:10 +0100
User-agent: Mozilla/5.0 (X11; OpenBSD amd64; rv:45.0) Gecko/20100101 Thunderbird/45.2.0


On 02/28/17 12:02, Steven Nunez wrote:
The config line for FreeBSD 11 (zsh), with GNUStep installed from packages:

env CFLAGS=-DGNUSTEP ./configure --with-ns --with-gnustep-conf=/usr/local/GNUstep.conf

Given all the difficulty that seems to surround this, I thought I would confirm that it will actually work before banging my head on this one too much longer.

getting emacs on GNUstep again would be lovable!

On OpenBSD I tried this line:
./configure --with-ns CC=egcc CXX=eg++ LDFLAGS=-Wl,-R/usr/local/lib

That means, no particular options except those I need to pass to configure gnustep-make itself (I am using a compiler different than the one in base which removed obj-c support)

With 25.1 it configures and get much further than you (did you source GNUstep.sh before? I did not need other flags as you see) but eventually fails during build:
  CC       nsfns.o
nsterm.m:72:18: error: conflicting type qualifiers for 'NSMenuDidBeginTrackingNotification'
 extern NSString *NSMenuDidBeginTrackingNotification;
In file included from /System/Library/Headers/AppKit/AppKit.h:88:0,
                 from nsgui.h:34,
                 from dispextern.h:76,
                 from nsterm.h:21,
                 from nsterm.m:48:
/System/Library/Headers/AppKit/NSMenu.h:823:31: note: previous declaration of 'NSMenuDidBeginTrackingNotification' was here
 APPKIT_EXPORT NSString* const NSMenuDidBeginTrackingNotification;
gmake[1]: *** [Makefile:382: nsterm.o] Error 1

emacs 24.5 dies with the same error.

I just commented the declaration out. Build then completes, but I get:

on 25.1:
./temacs --batch --load loadup bootstrap

GNUSTEP Internal Error:
The private GNUstep function to establish the argv and environment
variables was not called.
Perhaps your program failed to #include <Foundation/NSObject.h> or
If that is not the problem, Please report the error to bug-gnustep@gnu.org.

gmake[1]: *** [Makefile:737: bootstrap-emacs] Error 1



reply via email to

[Prev in Thread] Current Thread [Next in Thread]