[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issue: GNUstep installation on Ubuntu 16.04

From: Patryk Laurent
Subject: Re: Issue: GNUstep installation on Ubuntu 16.04
Date: Sun, 14 May 2017 08:42:36 -0700

Hi Mark,

This may be related to an issue reported by Josh Freeman on this list in late 
April (4/23). The crashes he observed also had to do with graphics.

To work around it I think he simply checked out slightly older versions of the 
GNUstep repos.  Josh provided an altered compilation script to do this as an 
attachment to his emails to the list. 


> On May 14, 2017, at 07:37, Mark Clements <mark.clements@ki.se> wrote:
> I am having problems installing GNUstep on Ubuntu 16.04.
> I uninstalled all GNUstep packages and cleared /usr/GNUstep and
> /usr/local/lib/GNUstep. Then I followed the instructions from
> http://wiki.gnustep.org/index.php/GNUstep_under_Ubuntu_Linux. Running
> the test at the end using
> make
> openapp ./GUITest.app
> gave a segmentation fault. I then tried running the test programs using
> the command line and they worked. The problem seemed to be that the
> arguments -lgnustep-base -lgnustep-gui were not passed to
> $GNUSTEP_MAKEFILES. Does anyone know why?
> uname -a
> Linux L0311MEB 4.4.0-78-generic #99-Ubuntu SMP Thu Apr 27 15:29:09 UTC
> 2017 x86_64 x86_64 x86_64 GNU/Linux
> clang --version
> clang version 3.8.0-2ubuntu4 (tags/RELEASE_380/final)
> Target: x86_64-pc-linux-gnu
> Thread model: posix
> InstalledDir: /usr/bin
> It would be really nice to use libobjc2 and libdispatch. Is there an
> alternative installation route on Ubuntu?
> Kindly, Mark.
> _______________________________________________
> Discuss-gnustep mailing list
> Discuss-gnustep@gnu.org
> https://lists.gnu.org/mailman/listinfo/discuss-gnustep

reply via email to

[Prev in Thread] Current Thread [Next in Thread]