[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep make on MacOSX Sierra - application build fails

From: Ivan Vučica
Subject: Re: GNUstep make on MacOSX Sierra - application build fails
Date: Wed, 8 Nov 2017 20:57:16 +0000

On Tue, Nov 7, 2017 at 4:33 PM, Andreas Höschler <ahoesch@smartsoft.de> wrote:

I am not sure, does Apple ship 32bit frameworks on Sierra? Have you tried building 64bit!

(You edited my message, that had a question mark at the end, not exclamation :))

No, not yet.

I tried the following program on High Sierra:

#import <Foundation/Foundation.h>

int main() {
  [NSString stringWithUTF8String: "test"];
  return 0;

built with:

clang -arch i386 -framework Foundation /tmp/tmp.m -o /tmp/tmp

This is even more minimal than what you have, and (to my understanding) should work fine. It worked fine. It produced a 32bit-only binary:

$ file /tmp/tmp
/tmp/tmp: Mach-O executable i386

System frameworks are 32+64bit:

$ file /System/Library/Frameworks/Foundation.framework/Foundation
/System/Library/Frameworks/Foundation.framework/Foundation: Mach-O universal binary with 2 architectures: [x86_64:Mach-O 64-bit dynamically linked shared library x86_64] [i386]
/System/Library/Frameworks/Foundation.framework/Foundation (for architecture x86_64): Mach-O 64-bit dynamically linked shared library x86_64
/System/Library/Frameworks/Foundation.framework/Foundation (for architecture i386): Mach-O dynamically linked shared library i386

(1) If High Sierra has 32bit frameworks, then so does Sierra. OS is not the problem.
(2) What’s in /Library/Frameworks? Why is it there and since when ("ls -al")?
(3) What does file "/Library/Frameworks/Foundation.framework/Foundation" print?

I retried an ancient version of GNustep make that I have in use for many years. It had trouble installing in some directories, but I got it finally working on Sierra. I will retry the current GNUstep make again and try to get hot working as well.

I suspect that you dropped in more than just GNUstep Make. I suspect semi-functional and 64bit-only Foundation and AppKit from GNUstep found their way onto your system as well. Please check /Library/Frameworks, which is what is being passed into framework search path by the makefile set you're using.
Any known issues with the recent GNustep make on MacOSX Sierra? Does anybody (except) me actually uses GNustep make on MacOSX?

I think there's some people, but there weren't really any discussions for a while now, whether about just using Make + GS additions, or about wider use on OS X.

PS It's GNUstep, not GNustep. :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]