discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Windows build failure...


From: Gregory Casamento
Subject: Re: Windows build failure...
Date: Mon, 27 Nov 2017 02:05:19 -0500

ICU is disabled in this build. If you look at the script which I use to build it uses the --disable-icu flag.  I'm thoroughly confused by this.

Can you share/point me to the scripts you are using to build?

Thanks, GC

On Sat, Nov 25, 2017 at 9:45 AM, Riccardo Mottola <address@hidden> wrote:

Hi,


On 20/11/2017 01:32, Gregory Casamento wrote:
 Compiling file GSFormat.m ...
GSFormat.m:99:18: error: conflicting types for 'wint_t'
c:\gnustep\bin\../lib/gcc/mingw32/4.6.1/include/stddef.h:353:23: note: previous declaration of 'wint
_t' was here
GSFormat.m: In function '_i18n_number_rewrite':
GSFormat.m:313:3: warning: implicit declaration of function 'alloca' [-Wimplicit-function-declaratio
n]
GSFormat.m:313:21: warning: incompatible implicit declaration of built-in function 'alloca' [enabled
 by default]
GSFormat.m: In function 'GSPrivateFormat':
GSFormat.m:919:9: warning: incompatible implicit declaration of built-in function 'alloca' [enabled
by default]
GSFormat.m: In function 'group_number':
GSFormat.m:2023:21: warning: incompatible implicit declaration of built-in function 'alloca' [enable
d by default]
make[4]: *** [obj/libgnustep-base.obj/GSFormat.m.o] Error 1
make[3]: *** [internal-library-all_] Error 2
make[2]: *** [libgnustep-base.all.library.variables] Error 2
make[1]: *** [internal-all] Error 2
make: *** [internal-all] Error 2

I am using the build script in tools-scripts/windows-build to do the compilation.   This is on windows 8.1 using our standard installer and trying to rebuild everything from scratch.

I have also tried deleting my installation and re-installing clean.  This doesn't help either.  I am completely stumped as to why this is happening.   Does anyone have any clue as to why this is not working on the trunk?

I don't have a real clue. I compiled using our own installer on two different computers and it worked fine.
Did you try disabling ICU? i8n is a clue about conflicting headers. The old ICU is not going to work anyway with current GUI.
I had install problems however with ICUs.
Furthermore, I would like to make a new and improved installer for us, with updated libobjc2 and ICU, but I don't know how to replace the components and package them together.
I'll try to sync with Adam once again. I somehow doubt it will solve your issue though.

Riccardo
An alternative is installing a newer ICU



--
Gregory Casamento
GNUstep Lead Developer / OLC, Principal Consultant
http://www.gnustep.org - http://heronsperch.blogspot.com
http://ind.ie/phoenix/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]