discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

enumerateObjectsWithOptions:usingBlock - runtime error "incorrect signat


From: Tom Sheffler
Subject: enumerateObjectsWithOptions:usingBlock - runtime error "incorrect signature"
Date: Mon, 27 Nov 2017 09:25:10 -0800

I have the following code

  [mutarray enumerateObjectsWithOptions:NSEnumerationReverse usingBlock:^(NSObject *o, NSUInteger idx, BOOL *stop) {
    ...}];

This compiles and runs fine on one installation of gnustep on Ubuntu16, but on a different installation, I get the following runtime error:

Calling [GSMutableArray -enumerateObjectsWithOptions:usingBlock:] with incorrect signature.  Method has address@hidden:8Q16^{?=^vii^?}24, selector has address@hidden:address@hidden

I believe my failing installation has an older version of gnustep-base.  Both use clang 3.8.0-2ubuntu4.  Both installations of gnustep are from git repos.  I believe the failing one is an older installation, so I am not very concerned about it.  But I am wary.

Has anyone else seen this?  I tried modifying the block in a number of ways, and couldn’t find an incantation that worked.

Thanks,
Tom


reply via email to

[Prev in Thread] Current Thread [Next in Thread]