[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gorm can edit which types of files ?

From: Daniel Santos
Subject: Re: Gorm can edit which types of files ?
Date: Thu, 28 Dec 2017 19:00:40 +0000

Here are the details of the error I am getting :

The backtrace : 

(gdb) bt 5 
#0  +[Utilities folderNodesFromFolders:separator:] (self=<optimized out>, _cmd=<optimized out>, theFolders=0x555555d49e20, theSeparator=<optimized out>)
    at Utilities.m:602
#1  0x00007ffff7b3470a in +[Utilities initializeFolderNodesUsingAccounts:] (self=<optimized out>, _cmd=<optimized out>, theAccounts=0x555555e67fc0)
    at Utilities.m:1045
#2  0x00007fffebebce71 in -[AccountEditorWindowController initWithWindowNibName:] (self=0x555555f5ebb0, _cmd=<optimized out>, windowNibName=<optimized out>)
    at AccountEditorWindowController.m:104
#3  0x00007fffebeb764c in -[AccountViewController addClicked:] (self=0x555555b8f990, _cmd=<optimized out>, sender=<optimized out>)
    at AccountViewController.m:235
#4  0x00007ffff65ad502 in -[NSApplication sendAction:to:from:] (self=<optimized out>, _cmd=<optimized out>,
    aSelector=0x7fffec0d26f0 <_OBJC_SELECTOR_TABLE+2128>, aTarget=0x555555b8f990, sender=0x555555f68a80) at NSApplication.m:2249

in the method folderNodesFromFolders: separator: in the Utilities.m file : 

line 584
i = [aString indexOfCharacter: theSeparator];
aString : Drafts
theSeparator : /
i : 9223372036854775807

line 602
aName = [aString substringWithRange: NSMakeRange(mark, i-mark)];
aString : Drafts
mark : 0
i : 9223372036854775807

when I step over this last instruction an exception is raised or something, in gdb the program just continues.
Obviously the substring with the range is the problem, but how does i get that value from the indexOfCharacter method on line 584 ?

On 28 Dec 2017, at 13:27, Daniel Santos <address@hidden> wrote:

Hi Riccardo,

I was able to read your email, so you fixed it.
What led me to Gorm and opening the GNUMail nibs in it, was that in my debian 9 VM (that I use to build and run gnustep), I bumped into a problem. When I open the preferences dialog and in the accounts section I press either the Add or Edit buttons, they stay pressed and no new window appears. 
So my first approach was to open the NIB file in Gorm and see which target/method was linked to the buttons.
Then I noticed that I could not select anything inside the panel. I wanted to select the button but no red selection dots appeared and the inspector didn't update to reflect the component I was selecting. Then I tried opening a gorm file and selection of components works for those files.

As to to GNUMail button problem, I am following the code in gdb, and right now I don't remember the spot where the error occurs and do not have access to the VM to get it. (I am at my day job). When I get home I can reply with the class and method where the I suppose the error is occurring.

As I understand, the GNUMail application is developed in Macs and then compiled for Linux, right ? 


On Wed, Dec 27, 2017 at 10:38 PM, Riccardo Mottola <address@hidden> wrote:
Hi Daniel,

On 2017-12-25 21:04:04 +0100 Daniel Santos <address@hidden> wrote:

> Hi and Merry Christmas,
> I was trying to select elements on one of the NIB files in the GNUMail
> project, a noticed that I can’t seem to do that on NIB files, only on Gorm
> files.
> Is it really lijke that ? Or am I missing something ?

A question: what are you trying to do? Modifying a specific NIB file? or Gorm File?
It is best to manipulate gorm files with Gorm, NIB files with the appropriate XCode version.

A bit of history: GNUMail was originally written for GNUstep my Ludovic and it laid out the interface with code, no Gorm files back then, perhaps for programmer's preference, but also because Gorm was much more primitive almost 20 years ago! It didn't even exist in its current state and gmodel files were used.
Later, GNUstep was ported to Mac but the interface was adapted and laid out differently and also employed NIB files. You can notice that in many interface classes which have different init code for MACOS and "else" which is GNUstep. The Mac vintage is about 10.3 /10.4 and with that he project and NIB files are best edited and GNUMail perfectly runs on those. I am doing quite some work recently to clean up the project on 10.5 and Intel and work for updating also to 10.6 and 10.7 is done too. I  do my best that all improvements still maintain GNUstep and "old mac" compatibility, since I find it cool that I can read email also on my vintage iBooks, one runnint 10.3 Mac and one GNUstep on GNU/Linux.

In recent times, I started also updating piece after piece GNUMail interface code to use Gorm files and not code, so or some parts you may have either a NIB or a Gorm file available. I will continue this work in the next months, although a certain core will be difficult since the Controller behaves differently from Mac to GNUstep.


PS: You got a blank email because you triggered a bug in GNUMail itself and the way it handles encodings. I investigated many hours and cleaned up the code and mitigated it. If you can read this Mail, I was successful :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]