[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling gnustep-make

From: Svetlana Tkachenko
Subject: Re: Compiling gnustep-make
Date: Thu, 01 Feb 2018 09:39:33 +1100

Hello All,

Ivan Vučica wrote:
> Have you uninstalled a previous installation of GS fully? Have you cleared 
> away your environment of GNUSTEP_* variables and deleted /etc/GNUstep.conf?
> If you did, it’s worth figuring out why that variable is making an appearance.

I now did 'apt purge *gnustep*' and that showed that some packages still needed 
removal. However I then rebooted and tried to compile GNUstep Make again and it 
produced the same error message. The workaround proposed by Riccardo appears to 
work (see below).

Yavor Doganov wrote:
> В Tue, 30 Jan 2018 06:35:03 +1100, Svetlana Tkachenko написа:
> > Then the following error message:
> > config-noarch.make:121: *** GNUSTEP_USER_ROOT is obsolete
> When is this "then"?  When you run `make' after the successful
> configure run of gnustep-make, when you run `make install' for
> gnustep-make or when you attempt to build a random GNUstep tool/app
> afterwards?

When I run make after the successful configure run of gnustep-make.

Yavor Doganov wrote:
> If you intend to use a pristine GNUstep installation on a Debian
> system, it's much better to wipe out all GNUstep-related Debian
> packages.  Or you can install in the USER domain which always takes
> precedence. 

How do I install in the USER domain?

Yavor Doganov wrote:
> That's what I'm doing and it works nicely except when
> testing changes to GNUstep Make.

Why don't you install GNUstep Make into the USER domain as well?

> If you have problems with the Debian packages, please report them to
> the Debian BTS; thanks in advance.  If my theory above is correct,
> this is not a problem in the Debian gnustep-make package.  Rather,
> it's a problem in the upstream build system which is assuming things
> it shouldn't.

Riccardo Mottola wrote:
> try sourcing GNUstep-reset.sh before configuring and installing 
gnustep make, then after source GNUstep.sh again and get the "new" 
updated environment set up.

This works. GNUstep-make compiles. Now gnustep-base says objc headers are 
missing, what package is that in Debian? I already tried objc*dev but the error 

-- Sveta

reply via email to

[Prev in Thread] Current Thread [Next in Thread]