[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep + libobjc2 and powerpc ( was "libobjc2 on powerpc")

From: bertrand
Subject: Re: GNUstep + libobjc2 and powerpc ( was "libobjc2 on powerpc")
Date: Thu, 22 Mar 2018 10:29:22 +0100

> >>> 4. The script on the wiki builds and install gnustep-make two times :
> >>> before and after libobjc2 ? Is it still correct ?
> >> 
> >> No, that’s definitely wrong.  It dates back to when I tried to use GNUstep 
> >> Make to build libobjc2, but that led to circular dependencies.
> >> 
> > Then should I build libobjc2 before of after gnustep-make ?
> After.  Now libobjc2 doesn’t depend on GNUstep Make.
> David

Hi everyone,
I'm trying now to build base and failed.

I've tried all that I could find on the list or on the internet:
- building make twice or only once after libobjc2
- installing libobjc2 in /usr , /usr/local, or even
in /usr/GNUstep/Local/Library/Libraries/ (I use GNUstep layout) by hand
- building without gcc's gobjc-4.9.deb and gobjc++-4.9.deb (I thought
they weren't mandatory) or with them.

I've even added --enable-install-ld-so-conf to gnustep-make configure.

My configure options for make are : 

./configure --enable-debug-by-default --with-layout=gnustep
-enable-objc-nonfragile-abi -enable-objc-arc --enable-install-ld-so-conf

and I had set OBJCFLAGS="-fblocks -fobjc-runtime=gnustep-1.8.1" before
the last install of make and run ldconfig just before configuring base.

Each time, the configure step of base fails with the well-known and

> checking whether objc really works... no
> I don't seem to be able to use your Objective-C compiler to produce
> working binaries!  Please check your Objective-C compiler installation.
> If you are using gcc-3.x make sure that your compiler's libgcc_s and libobjc
> can be found by the dynamic linker - usually that requires you to play
> with LD_LIBRARY_PATH or /etc/ld.so.conf.
> Please refer to your compiler installation instructions for more help.
> configure: error: The Objective-C compiler does not work or is not installed 
> properly.

Here is attached my config log attached, when  gnustep-make was installed 
before and after libobjc2, ithout gobjc-4.9.

Any idea ?


Attachment: config.log
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]