discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: clang versions for libobjc2


From: Andreas Fink
Subject: Re: clang versions for libobjc2
Date: Tue, 19 Feb 2019 21:14:29 +0100

and the lld linker can not be use to compile libobjc2 and gnustep-base neither. 
So we are in deep water here.

> On 19 Feb 2019, at 21:11, David Chisnall <address@hidden> wrote:
> 
> On 19 Feb 2019, at 18:55, Andreas Fink <address@hidden> wrote:
>> 
>> There is definitively some nonsense  happening when library A has an object 
>> wich librarby B is subclassing and App usese library B and sets a property 
>> of the superclass library A.
> 
> This is a known issue with the pre-2.0 ABI on Linux and was one of the 
> motivations for the new ABI.  It began to appear with fairly recent 
> ld-linux.so and has become deterministic with subsequent releases.  You will 
> see this on *any* libobjc2 release with *any* version of clang on *any* 
> system that uses glibc’s run-time linker.  
> 
> I don’t know if it appears on Android with the bionic run-time linker, it 
> does not appear on any other platform that I’ve tested.
> 
> David
> 





reply via email to

[Prev in Thread] Current Thread [Next in Thread]