[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Dolibarr-dev] X_pdf_create

From: Maxime Kohlhaas
Subject: Re: [Dolibarr-dev] X_pdf_create
Date: Mon, 15 Sep 2014 15:40:08 +0200

Agreed, and I think this should be in the CommonObject class.
And the method should be called within the class (by validate or update or addline functions) and not in the xxx.php file in each case action = "" action = "" ...

Bien cordialement,

Maxime Kohlhaas
Consultant associé
ATM Consulting
+33 6 33 42 92 43

2014-09-15 12:49 GMT+02:00 Marcos García <address@hidden>:
Hi all:

I've noticed that there are many functions called x_pdf_create (expedition_pdf_create, ...) that are used to create documents of a specified object.

I was thinking that because this function depend on a given Object, why not implementing them as a public function of the given class? We'll keep the old functions for compatibility but I think moving the function with a generic name like generateDocument or createDocument will be better than the actual implementation.

What do you think?

Marcos García

Dolibarr-dev mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]