[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [DotGNU]Platform testers wanted

From: Glenn Chambers
Subject: Re: [DotGNU]Platform testers wanted
Date: Mon, 6 Jan 2003 21:56:14 -0500

On Sunday, January 5, 2003, at 08:57 PM, I wrote:

Tests so far:

NetBSD 1.5.5 on x86:

pnetC fails to configure; /usr/bin/cpp is a shell script that
runs the real 'cpp', and it's choking on something it's being fed and thinks it's preprocessing STDIN, so it just hangs until you hit EOF during the C compiler check.

I haven't tried to debug this beyond this point. I'll try to get back to it tomorrow.

Ok, I've continued to fiddle with it, with the following results.

1)  The failing process tree looks essentially like this:

  -> cscc ...
    -> cscc-c-s ...
      ->  /bin/sh /usr/bin/cpp ...
        -> /usr/libexec/cpp -traditional ...

As nearly as I can tell by inserting ECHO commands into the /usr/bin/cpp script, by the time the script starts looping over its arguments, there is no quoting left, so it treats '-D __SIZE_TYPE__=unsigned int' (note embedded spaces) as three seperate arguments, which means it tries to treat the '__SIZE_TYPE__' as an input file to parse. This is notably unsuccessful, and things go rapidly downhill from there.

Perusing the code, I noticed the "CPP" environment variable, so I tried
"setenv CPP /usr/libexec/cpp" and reconfigured.

This time, I got a successful configure, and a successful build. All samples where
run, and all succeeded.

I was unable to figure out how to induce the C compiler to echo the commands it was running, so I can't tell if there was any quoting that got lost along the way. Hints
are welcomed.

I'm out of hacking time for tonight, so off to bed. Tomorrow, I'll see what I can find out about debugging the FreeBSD crashes, and trying a MacOS X build. (I'll have to fiddle with that a bit, since I don't have AUTOMAKE on this Mac. I'll probably just run in each directory on a different box, then tar that
up and move it to the iMac.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]