[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [DotGNU]X11 support on Mac OS/X

From: Andrew Troelsen
Subject: Re: [DotGNU]X11 support on Mac OS/X
Date: Tue, 19 Aug 2003 21:02:47 -0500

Hey there Oscar. The problem you are having pestered me for over 2 weeks. Here is the way I finally got it to work on my Mac:

-> First, the posted binaries (pnetlib in particular) have a problem in that they do not generate the correct file extension for the Mac OS (*.dylib). So, delete those from your machine and instead download the CVS files (I downloaded the whole directory) where this issue has been fixed. If you are not sure how to run CVS, pop me an e-mail and I'll help!

-> Next, the directories for treecc, pnetlib and pnet don't have the 'configure' files, so you need to first run the script in each directory. This generates configure, so at this point simply ./configure, make, make install.

-> Finally (as you already may know) be sure you execute XDarwin (rootless or full screen) before trying to run any of the Windows Forms examples. Although non-GUI C# apps run outside of XDarwin (e.g. at the Mac Terminal), the GUI apps do not.

-> Finally (finally) be aware that the XHello.exe app does not work yet (at all) as there needs to be some work to host the image file. However all the other GUI examples in the pnetlib/Samples folder do!

Hope this helps you out.  let me know if I can be of any assistance.

Andrew Troelsen

On Monday, August 18, 2003, at 08:58 PM, Oscar Papel wrote:


I downloaded and compiled the latest versions of treecc/pnet/pnetlib and built them into my /usr/local directory. I tried running the sample programs and the command-line Hello program runs fine. I then tried running XHello.exe and got the following error message:

libXsharpSupport.dylib: could not load dynamic library (NSObjectFileImageAccess) Uncaught exception: Xsharp.XCannotConnectException: X/Windows library is not present, or could not be
located on the library search path.
at Xsharp.Display.OpenInternal(String, Application) in ./Display.cs:194
       at Xsharp.Display.Open(String, Application) in ./Display.cs:204
at Xsharp.Application..ctor(String, String[]) in ./Application.cs:252
       at XHello.Main(String[]) in ./XHello.cs:29

I'm running Mac OS/X 10.2.6 with the Dec 2002 devel tools
I am using the X11 supplied by Apple (public beta 3) as well as the corresponding X11 SDK

I can run other X11 apps fine from the command line (xeyes, xclock etc).

I don't have any dynamic library called NSObjectFileImageAccess on my computer.
Is there something that i'm missing?

Thanks for any help,


Tired of spam? Get advanced junk mail protection with MSN 8.

Developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]