[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [DotGNU]error building XSharp on Mac OS X [solved?]

From: Rob Saul
Subject: Re: [DotGNU]error building XSharp on Mac OS X [solved?]
Date: Wed, 17 Sep 2003 09:51:40 -0700

On Monday, September 15, 2003, at 06:14  PM, Jason Batchelor wrote:

The only way I resolved it was by copying libtool into the pnetlib directory... I'll have to look around for the directions, but I think it was found under /usr/bin/libtool

Anyhow, i copied the directory into the pnetlib dir, and re-ran the, configure, make clean, then make, and then sudo make install, and it seemed to work fairly well after that... at least, the installers finished.

Good luck!

after sniffing through libtool and sh -x output I noted that SED wasn't getting set somewhere in the configuration process. I also noted that dotGNU uses libtool 1.4, while fink libtool is 1.3.5. Fortunately the fink project also has the former available as the package libtool14. I installed that, rm'd my copy of the
source from CVS and did a fresh pull.

The I did
export LIBTOOL=glibtool
export SED=/usr/bin/sed

and did the build/install process.  After this I was able to compile
and run a simple 'HelloWorld' C# program.  I'll try some of the samples
when I have a free moment.  Hopefully this will help others.


Rob Saul.|address@hidden|.prohibitions void where offered
                                  de recta non tolerandum sunt

reply via email to

[Prev in Thread] Current Thread [Next in Thread]