[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[DotGNU]Minor glitches in 0.6.2 on Windows

From: Maciek
Subject: [DotGNU]Minor glitches in 0.6.2 on Windows
Date: Sat, 13 Mar 2004 01:31:10 +0800
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.6) Gecko/20040113


I've recently built the 0.6.2 release on Windows/Mingw, and I thought I'll share my experience with you:

First of all, it was impossible to compile pnet-0.6.2 with the latest Cygwin (I haven't tried with previous versions though). After specifying "-no-cygwin" option to configure script, the make process would still insist on using Cygwin includes such as sys/utsname.h, langinfo.h, locale.h, etc., which are not present in mingw include directory. I think the problem is that the configure script erroneously detected Cygwin environment even though it received the '-disable-cygwin' option.

Building on the latest Mingw was much more pleasant. After downloading some required packages (libiconv, zlib, bison, flex - please mention this on requirements page) and starting the make process, some minor problems came up:

1 - It seems the autoconfig file wasn't prepared for running on pure mingw (i.e. not as part of cygwin) and didn't enforce using wsock32 for SOCKETLIBS. The objects that failed were 'ilverify.exe' and 'ilrun.exe'. I've fixed it by compiling those files by hand (with '-lwsock32') because I'm not familiar with using autoconf. If someone can fix it, it would also be a good idea to perhaps skip '-lm' if it's not necessary.

2 - Second problem occured in installation phase. The linker couldn't create a hard link from 'ilsize' to '/usr/local/bin/cli-unknown-size' claiming that 'ilsize' cannot be found, even though 'ilsize.exe' was in the directory. This problem repeated with other executables. What can be done about this issue? Is it Mingw problem?

That's about it.. The tests run correctly, except for some exceptions in the Forms sample.

I hope the wsock32 problem can be corrected before 0.6.4 release. I'd submit a patch myself but I'm not proficient in autoconfig and Unix shell scripting.

Thank you for your time and DotGNU :)


Maciek Plewa

reply via email to

[Prev in Thread] Current Thread [Next in Thread]