[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Pnet-developers] [Bug #3586] Pnet fails to build

From: nobody
Subject: [Pnet-developers] [Bug #3586] Pnet fails to build
Date: Sun, 08 Jun 2003 05:47:13 -0400

=================== BUG #3586: LATEST MODIFICATIONS ==================

Changes by: Anonymous user        Date: Sun 06/08/03 at 05:47

------------------ Additional Follow-up Comments ----------------------------
The system builds now , but still not confirmed to work ?

=================== BUG #3586: FULL BUG SNAPSHOT ===================

Submitted by: mathpup                 Project: DotGNU Portable.NET          
Submitted on: Tue 05/13/03 at 20:10
Category:  None                       Severity:  5 - Major                  
Bug Group:  None                      Resolution:  None                     
Assigned to:  None                    Status:  Open                         

Summary:  Pnet fails to build

Original Submission:  Pnet fails to build with GCC 3.2:

make[1]: Entering directory `/home/marcus/src/pnet/engine'
gcc -DHAVE_CONFIG_H -I. -I. -I../include    -I../libffi/include -fno-gcse 
-fno-inline-functions -I../include -I../libffi/include -I. -O3 
-march=athlon-tbird -mpreferred-stack-boundary=2 -pipe -Wall -c `test -f 
'cvm.c' || echo './'`cvm.c

cvm.c: In function `_ILCVMInterpreter':
cvm.c:693: unable to find a register to spill in class `GENERAL_REGS'
cvm.c:693: this is the insn:
(insn 4757 4756 4758 (parallel[
            (set (reg/v:DI 1826)
                (ashift:DI (reg/v:DI 1826)
                    (subreg:QI (reg:SI 1828) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ] ) 405 {ashldi3_1} (insn_list 4753 (insn_list 4756 (nil)))
    (expr_list:REG_DEAD (reg:SI 1828)
        (expr_list:REG_UNUSED (scratch:SI)
            (expr_list:REG_UNUSED (reg:CC 17 flags)
cvm.c:693: confused by earlier errors, bailing out
make[1]: *** [cvm.o] Error 1

Follow-up Comments

Date: Sun 06/08/03 at 05:47         By: None
The system builds now , but still not confirmed to work ?

Date: Wed 05/28/03 at 11:20         By: scandium
This has something to do with -march
It works with e.g. -mcpu=* but -march=* breaks the compilation

CC list is empty

No files currently attached

For detailed info, follow this link:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]