[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Pnet-developers] HELP needed to run winforms apps in OSX

From: Gopal V
Subject: Re: [Pnet-developers] HELP needed to run winforms apps in OSX
Date: Tue, 24 Jun 2003 13:56:51 +0530
User-agent: Mutt/1.2.5i

If memory serves me right, Enrique Zamudio wrote:
> I have OSX 10.2.6 with Apple's X11 server. First, the error I got was:
> [qix:fuentes/pnetlib/samples] ezamudio% ilrun XHello.exe

Ok, unless you've already make installed pnetlib this is the wrong thing
to do ...

You should run 

$./ XHello.exe 

read to see the paths and parameters supplied to ilrun to be
able to run stuff without having to install it.

But if you're not getting a .dylib in ${prefix}/lib/cscc/lib/ after install
then this is not *THE* problem :-)

> Additionally, what about that "cannot connect" exception? will it go away if
> I compile XsharpSupport as a dynamic library?

Well that exception is thrown because it cannot resolve the PInvoke into
the libXsharpSupport.dylib ..

> I will appreciate any help I can get. I tried this first with 0.5.8 but now
> I'm using the freshest updates from cvs and still nothing. I don't have fink
> installed, I don't know if I need it, but I shouldn't...

I don't know how alias (Ian Fung) has managed to compile this and get 
this running . But absurd (B Bremen) had had to use the Fink libtool
to get this compiled .

The Apple libtool seems to be incompatible to the GNU things or at least
trying it with absurd seemed to point to that.

Jun 13 11:41:42 <absurd>        /usr/bin/libtool: unknown option character `-' 
in: --mode=compile
Jun 13 11:41:54 <absurd>        it then proceeds to output the usage help
Jun 13 11:42:01 <t3rmin4t0r>    your libtool is fscked up ?
Jun 13 11:42:09 <absurd>        its apple's libtool
Jun 13 11:42:13 <t3rmin4t0r>    *ouch*
Jun 13 11:42:14 <absurd>        i cant even get a version out of it
Jun 13 11:42:18 <absurd>        thats probably why it reports no version
Jun 13 11:42:19 <t3rmin4t0r>    double ouch
Jun 13 12:00:38 <absurd>        hmm i have glibtool and libtool
Jun 13 12:00:52 <t3rmin4t0r>    try glibtool --version
Jun 13 12:01:12 <absurd>        oh hell ya! a version number! w00t!
Jun 13 12:01:19 <absurd>        lets try that make again..
Jun 13 12:01:22 <t3rmin4t0r>    so make LIBTOOL=glibtool
Jun 13 12:01:31 <absurd>        done
Jun 13 12:01:34 <t3rmin4t0r>    it worked ?
Jun 13 12:01:37 <t3rmin4t0r>    w00t !
Jun 13 12:01:41 <absurd>        yes
Jun 13 12:01:45 <t3rmin4t0r>    cool ...
Jun 13 12:01:51 <absurd>        ok continuing with make
Jun 13 12:01:55 <absurd>        alright it made itself
Jun 13 12:02:06 <absurd>        installing

But don't install the fink pnet which is currently out of date (by 
about 14 months and 10 releases !!) ...

Hope that helps a bit,
The difference between insanity and genius is measured by success

reply via email to

[Prev in Thread] Current Thread [Next in Thread]