[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] Duplicity backup to rsync.net

From: Peter McCrackan
Subject: Re: [Duplicity-talk] Duplicity backup to rsync.net
Date: Thu, 14 Jan 2010 10:41:58 +0800

Hey, it looks as if I am fine now, I noticed there are different "providers" of duplicity on the OpenSuse web site, I removed the version I had setup previously and installed 0.6 from another provider and it seems as if it's working okay now.
Regards, Peter.

On Thu, Jan 14, 2010 at 8:51 AM, Kenneth Loafman <address@hidden> wrote:

It looks like the GnuPGInterface.py module is missing in their release.
 Duplicity provides a custom version of this module, so they may have
gotten confused and left it out.  You may want to check with them.

I would suggest installing the latest version, 0.6.06, from
https://launchpad.net/duplicity.  That will make sure you get all the
parts you need.


Peter McCrackan wrote:
> I have tried both with and without the -v9 switch (as per instructions
> at http://www.rsync.net/resources/howto/duplicity.html ), both give the
> same result.
> I have got the SSH key setup, as root I can log into my rsync.net
> <http://rsync.net> file system without entering a password.
> I have got my GPG key setup and get the expected results when listing it.
> It is not asking my for my passphrase when I run the command below, just
> says it cannot import the GnuPGInterface.
> I have changed my rsync.net <http://rsync.net> account details, the
> account details below are fictitious.
> duplicity full -v9 --encrypt-key="2F1A3E29"
> /media/b580000f-33eb-4192-91f9-f8d8d2a4024c/share/current
>  scp://address@hidden/dup-baks
> <http://myaccount@myfilesystem.rsync.net/dup-baks>
> Traceback (most recent call last):
>   File "/usr/bin/duplicity", line 41, in <module>
>     from duplicity import collections
>   File "/usr/lib64/python2.6/site-packages/duplicity/collections.py",
> line 29, in <module>
>     from duplicity import path
>   File "/usr/lib64/python2.6/site-packages/duplicity/path.py", line 745,
> in <module>
>     from duplicity import gpg
>   File "/usr/lib64/python2.6/site-packages/duplicity/gpg.py", line 30,
> in <module>
>     from duplicity import GnuPGInterface
> ImportError: cannot import name GnuPGInterface
> I installed Duplicity from the OpenSuse Web site as a one click install.
> It is the latest version (0.6).
> Thanks for any assistance you can give.
> --
> Peter McCrackan
> ------------------------------------------------------------------------
> _______________________________________________
> Duplicity-talk mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/duplicity-talk

Duplicity-talk mailing list

Peter, Jane and Sampson McCrackan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]