[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] Serious problem with duplicity - secret key not ava

From: Luca Bertoncello
Subject: Re: [Duplicity-talk] Serious problem with duplicity - secret key not available
Date: Thu, 12 Aug 2021 11:00:37 +0000

Hi Edgar,

I downloaded and installed Duplicity 0.7.19.
Unfortunately I always get the same problem... ☹

Any other idea?


-----Ursprüngliche Nachricht-----
Von: Duplicity-talk 
<duplicity-talk-bounces+l.bertoncello=queo-group.com@nongnu.org> Im Auftrag von 
edgar.soldin--- via Duplicity-talk
Gesendet: Donnerstag, 12. August 2021 12:43
An: duplicity-talk@nongnu.org
Cc: edgar.soldin@web.de
Betreff: Re: [Duplicity-talk] Serious problem with duplicity - secret key not 

On 12.08.2021 12:00, Luca Bertoncello via Duplicity-talk wrote:
> Hi list!
> I'm using Duplicity on many servers since years and did not even have a 
> problem...
> Now I have to backup a server (very old... it runs Ubuntu 16.04 and I cannot 
> upgrade it now).
> So I installed duplicity 0.7.06 from Ubuntu-Repository (GPG is 1.4.20) and 
> started the backup.
> It works, but after some days it does not work anymore I every call to 
> duplicity fails with:
> GPGError: GPG Failed, see log below:
> ===== Begin GnuPG log =====
> gpg: encrypted with 2048-bit RSA key, ID xxxxxxx, created 2021-07-19 
> "RESTORE <it@queo-group.com>"
> gpg: decryption failed: secret key not available ===== End GnuPG log 
> =====
> The key files are on the disk and readable.
> Do someone have an idea what I can do?
> I already had the problem on the server and I "solved" it creating new keys 
> and deleting all old backups, but this is not a solution...

hey Luca,

duplicity 07.06 is very very old and not even the latest in the now 
unmaintained branch. please install either latest duplicity 0.8.20 or 0.7.19 
manually after removing the old version from your distribution.
http://duplicity.nongnu.org/ (section Download)

there are ppa, snap and pip3 installations available. if that does not suffice 
or is impossible, there is a 'INSTALL MULTIPLE VERSIONS' mini-howto on 
https://duply.net/Documentation (never tried with 0.8.x though, the executable 
patching may need some modification there).

please come back if the error persists with one of the above versions and we'll 
try to resolve it for good.

good luck and healthy regards.. ede/duply.net

Duplicity-talk mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]