[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] Problem running duplicity from lauchd on Monterey

From: Jeffrey Simon
Subject: Re: [Duplicity-talk] Problem running duplicity from lauchd on Monterey
Date: Mon, 8 Aug 2022 09:01:26 -0600

The suggestion from Scott solved the problem. The launchd job path did not include /opt/local/bin. Adding that allows gpg to be found, and after adding that to the launchd path, the problem is completely solved.

Here is what my original post about this solution contained:

My conclusion is that prior to the Monterey upgrade, gpg was on the existing path, for whatever reason. Configuration changes due to that upgrade caused it no longer to be on the configured path.

I have also confirmed that the --gpg-binary flag is not needed either and so have removed that

So all the other follow up support on this thread is no longer required, as the simple solution of the path modification solves it completely.

Thanks to all for your input.


On Aug 5, 2022, at 12:52 PM, edgar.soldin--- via Duplicity-talk <duplicity-talk@nongnu.org> wrote:

comments inline

On Fri, Aug 5, 2022 at 10:28 AM Jeffrey Simon via Duplicity-talk <duplicity-talk@nongnu.org <mailto:duplicity-talk@nongnu.org>> wrote:

   Ever since I upgraded to macOS Monterey, a launchd job that includes a call to duplicity will no longer work.

    1. The job is a php script.

why php? can you provide it?

    2. An example of the command is as follows:

       env PASSPHRASE='************' /opt/local/bin/duplicity --gpg-binary /opt/local/bin/gpg --file-to-restore 20220805.s4.sql.rephunter.bz2 file:///Volumes/Backup1/RH-backup/20220805 /Volumes/Backup1/RH-backup/dbtemp/20220805.s4.sql.rephunter.bz2 >> /Users/jas/dbload.log 2>&1

this is a restore, not a backup command. am assuming your launchd run script does backups or?

    3. The script continues to work perfectly from the command line. My workaround is to run it from the command line.

again, pls provide the script

    4. A possible difference with Monterey is that previously gpg could have been installed in a macOS-determined location. However with Monterey gpg was installed by MacPorts. So it might be in a different location. Or prior to Monterey it could have been in the same location; hard to tell now.
    5. Duplicity is throwing error output which includes the line "GPGError: failed to determine gnupg version of None from b''

as Ken asked already. what is the output of `gpg --version` in the Terminal?

    6. Searching on that error gives a page at https://bugs.launchpad.net/duplicity/+bug/1865427 <https://bugs.launchpad.net/duplicity/+bug/1865427>, where the suggestion is to add --gpg-binary with the path to gpg.

possible, but generally providing proper PATH env var should do it as well.

    7. I have added --gpg-binary /opt/local/bin/gpg but it does not help: the same error message is thrown.

sounds like the out put is wrong?

   I have posted detail on this issue to https://apple.stackexchange.com/questions/443461/after-upgrade-to-monterey-a-user-created-launchd-job-does-not-run <https://apple.stackexchange.com/questions/443461/after-upgrade-to-monterey-a-user-created-launchd-job-does-not-run>

that reads a bit as if launchd is running as a different user with insufficient access rights. possible?

sunny regards.. ede/duply.net

Duplicity-talk mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]