[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Emacs-bug-tracker] bug#8654: closed (head)

From: GNU bug Tracking System
Subject: [Emacs-bug-tracker] bug#8654: closed (head)
Date: Wed, 11 May 2011 17:39:02 +0000

Your message dated Wed, 11 May 2011 10:30:22 -0600
with message-id <address@hidden>
and subject line Re: bug#8654: head
has caused the GNU bug report #8654,
regarding head
to be marked as done.

(If you believe you have received this mail in error, please contact

8654: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=8654
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: head Date: Wed, 11 May 2011 10:15:11 +0200

Hi I run the following line:


$ set header = `head -5 ~/buffer/t1xp_axi2rgv_fifo.vhd`


and get:


Missing }.


Any ideas?


Running on:

Red Hat Enterprise Linux AS release 4 (Nahant Update 7)

$ uname -r







Ivan Di Prima

Electronics Engineer


Chineham Business Park
RG24 8YB
United Kingdom

Office: +44 1256 303187
Mobile: +44 7881 857 467
Fax: +44 1256 303353

Email: address@hidden


This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interception, unauthorized amendment, tampering and viruses, and we only send and receive emails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.


Registered Address: ST-Ericsson (Uk) Ltd, Planar House, Parkway, Marlow, Buckinghamshire, SL7 1YL.  Company No 06637804


Attachment: t1xp_axi2rgv_fifo.vhd
Description: t1xp_axi2rgv_fifo.vhd

--- End Message ---
--- Begin Message --- Subject: Re: bug#8654: head Date: Wed, 11 May 2011 10:30:22 -0600 User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110428 Fedora/3.1.10-1.fc14 Lightning/1.0b3pre Mnenhy/0.8.3 Thunderbird/3.1.10
tag 8654 notabug
close 8654

On 05/11/2011 02:15 AM, Ivan DI PRIMA wrote:
> Hi I run the following line:
> $ set header = `head -5 ~/buffer/t1xp_axi2rgv_fifo.vhd`
> and get:
> Missing }.
> Any ideas?

Thanks for the report.  However, this is not a bug in head, but in your
usage of your shell.

What does this output:

head -5 ~/buffer/t1xp_axi2rgv_fifo.vhd

If it is not valid csh shell script (and I'm assuming your using csh,
based on your syntax for using set), then that explains why csh, not
head, is complaining that after the `` substitution has completed, the
resulting text can't be parsed (because it is unquoted, the shell may be
trying to do word splitting on the results, but is getting thrown off by
unbalanced {} in the words to be split).  I'm not a csh user, but does
adding "" around the `` help, as in:

set header = "`head -5 ~/buffer/t1xp_axi2rgv_fifo.vhd`"

I'm marking this bug closed, although we can always reopen it if you can
prove that the problem was in head rather than in your use of shell code.

> This communication is confidential and intended solely for the addressee(s).

It is considered poor netiquette to send email to publicly archived
lists with employer disclaimers, since such disclaimers are
unenforceable by nature of the public archival.  You may want to
consider sending from a different account when sending bug reports to
open source projects.

Eric Blake   address@hidden    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]